New to ssl, got CSR code from godaddy to upload to ssl, but I dont know how

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain

I ran this command: chatted with godaddy agent

It produced this output: he told me to "upload this CSR code to the SSL", but I don't know what that means because I am so new to ssl. He said to provide him with the .crt and bundle files and that he would activate ssl for me.
My web server is (include version): Economy Linux Hosting with cPanel

The operating system my web server runs on is (include version): Linux

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):I don't know

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):cpanel 94.0.19

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

1 Like

Welcome to the Let's Encrypt Community, J.D.! :slightly_smiling_face:

The easiest way to acquire a Let's Encrypt certificate as a GoDaddy customer is to use :man_mage: CertSage.


Thank you Griffin. I will check it out.


BTW - @jdbunnell2, @griffin is a darn good guy! :slightly_smiling_face:


Hi Griffin, I downloaded CertSage and then renamed certsage.txt to certsage.php, then uploaded to my website, then opened a chrome browser window to the webpage that certsage.php is in but it gave me a 404 error. I then uploaded certsage.php to public_html and then tried it there and still got a 404 error. Do you know what I did wrong?

1 Like

Your browser cache got in the way? :wink:


it wasn't the cache, but I got it to run and put in my domain name and clicked the production button instead of the staging button. Then I copied the certificate text from certificate.crt. Next in your instructions I closed the file and went to my sites files, but I don't see anything that says security. Can it be called anything else?

Maybe it is just the way you describe it but

You don't go to sites files, you go back to cPanel tab and its SECURITY section per:

  1. Click Close.
  2. Switch back to the cPanel tab.
  3. Scroll to the SECURITY section.
  4. Click on SSL/TLS (not SSL/TLS Status).
    (... and continue ...) at:

Thank you MikeMcQ. My faux pas. Copied and pasted certificate and then tried to do the same with the key and install, but now it is saying the " * The CA bundle is invalid." How did I mess up this time?


If you need the CA bundle explicitly, it is the second certificate in certificate.crt. The first certificate in that file is your certificate. The third certificate in that file is an intermediate-root certificate that you shouldn't need to use.

You should only be pasting the first certificate from certificate.crt into the certificate box in cPanel, not all three certificates.


I tried following the instructions that you sent to me for certsage ACME client. I did only copy the first text from certificate.crt file, not the 2nd nor 3rd. Continuing down the instructions and selecting my domain, I pasted the certificate in the Certificate box and then the private key into its box, that is when it gave me the error "The CA bundle is invalid." Should I delete certsage.php and some other files and start over again?

Absolutely not. You have successfully acquired a certificate. Now it's just a certificate installation problem, which has nothing to do with the CertSage software.

There's a cabundle box, correct? Did you try filling it per my previous post?


Finally, without doing anything else I clicked for it to install and it succeeded. Now I'm continuing your instructions and all seems good. What is the next step that I do in 60 days when this certificate expires?

1 Like

The certificate expires in 90 days. Before then you'll need to repeat the same process you just used in order to renew your certificate.


Thank you very much for your help


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.