# Your clock is ahead

A private connection to can't be established because your computer's date and time (Saturday, October 2, 2021 at 12:48:50 PM) are incorrect.


No solution I understand what I already read on related forum topics except Firefox only web browsing, since I manually installed R3 and X1 certificates and problem persists on IExplorer, Chrome, Opera:

I can't visit website which are certificated by R3 and by LetsEncrypt.

Website publishers should reconsider SSL certificate usage and serve over TCP 443 and at least offer the possibility TCP 80 with no SSL.

We don't give any critical information except banking, purchase etc. Why SSL usage? Prevent users to access web content if they are not rich to afford newest computer which regularly updates Microsoft.

Hi @safak.kayhan welcome to the LE community forum :slight_smile:

That is a weird error.
Have you checked your system time and timezone?
Does your system use an NTP source to sync time with?


You need to educate yourself before you make such unfounded comments.
A certificate expired that is causing problems for many users.
Of the two remaining trust paths, Let's Encrypt choose to keep the longer path as to allow older versions of Androids to be able to continue reaching sites that use LE certs.

The problem you show has NOTHING to do with a cert - it has to do with a bad clock/time sync.

I'm removing the unnecessary language at the end of your post - as irrelevant to this and rude.


Hi. Thank your for answer. In fact, I did a lot including your suggestions, reinstallation of the browsers, firewall issues etc, all I can imagine as an IT specialist. Then emailed LetsEncryt support enclosed above::

Dear Sir/Madame,

I'm writing you from Turkey, my name is Safak Kayhan, related to a difficulty I experienced during my latest visits to some websites which are using LetsEncrypt certificatiion for their SSL certification.

I first noticed this issue yesterday when I revisit Then today same issue appeared for Finally I checked for one more EU originated website

which I use occasionally With the browsers which use Microsoft certification utility such as Opera, Chrome and MS IExplorer this problem is 100% reproducable at my laptop computer (not others).

Finally when I couldn't solve the problem, I bypassed it and reinstalled Mozilla Firefox which uses it's own SSL method for certification process to connect above mentionned websites.

Thinking that this may be related with a malicious attack to my computer and might pose potential danger for other users as well in future, I prefered to inform you.

A solution would be great but a precaution seems just appropriate.

With my kind regards.

Safak Kayhan

PS1: The error message on Opera browser:

Your clock is ahead
A private connection to can't be established because your computer's date and time (Friday, October 1, 2021 at 8:30:39 AM) are incorrect.

PS2: I erased Let's Encrypt certificate from Microsoft certificaiton utility to overcome the problem. How can I restore or install it back without opening MS update service. Thank you.

No support available answer suggested this silent forum. Thanks anyway.



You can find all the Let's Encrypt certificates at:
Chain of Trust - Let's Encrypt (


Let's Encrypt, as a free service and not-for-profit organisation (ISRG), does not have e-mail support. This Community is the support channel.


@safak.kayhan It was most likely me who sent you the canned email response to point you here, either way, welcome to the community forum!


Hi again,

Thank you rg305, I did it before but I reinstalled them after your suggession and now I have all four certs:
and one unchanged result: Net::err_cert_date_invalid
Osiris thank you too for your answer. I know and appreciate your volunteer effort. However reinstalling OS or upgrading browser isn't a desired, real solution but bypassing. Robustness required and appreciated.
Phil thank you for your touch. You made me remember that Genesis is one of my all time favorites.
PS: In fact yesterday after I installed's LetsEncrypt certificate taken from your database, it worked. Today ceased working again but I already gave up for instance and Firefoxing.

1 Like

Hi Folks, same problem with windows XP and Chrome 49.x.x, IE8, yandex,
but all firefox like browsers ar ok, this behavior is happening since 3 to 4 days indeed.
in certificate status it says "This certificate has expired or is not yet valid."
my clock is absolutely syncrhonized and correct with the current time, timezone pacific +8

Hi @ROBERT-MCDOWELL welcome to the LE community forum :slight_smile:

I won't lecture you about the security risks of using WinXP...
[you should have heard that plenty already]

Have you tried adding the LE roots into the Windows trust store?
You can get them at: Chain of Trust - Let's Encrypt (


In fact, chasing down the problem of LetsEncrypt signed websites' Net::err_cert_date_invalid error a bit more, now I'm almost sure that this is a malicious attack by kinda PUP or alike to a single machine..

This malware probably poisons DNS related registry records and prevent access to internet for LetsEncrypt signed websites. In fact nslookup works also properly except

However, reinstallation of my anti-virus software and safe mode full search turned home back with empty hands. I messed up at registery server some but couldn't find a clue.

Since there are many other computers on same LAN and solely the one I use to write this message has this problem (I laso resetted all routers and modem) I think this thing is just at other side of the corner, in range but some experienced help apparently needed and will highly be appreciated.


PS: Win7 with Service Pack 1 installed. All windows SSL certificate utility user browsers which are under influence, are up to date as hell.

No worry for XP, I know why I'm using it....
I rebooted on windows 10 last update + chrome last version and strangely
it happened the same until I force the page to confirm it's a good cert...
did not happen on edge, opera, firefox and chromium

also I indeed forced to install again the LE root but still the same on XP, chrome down but others OK

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.