NET::ERR_CERT_COMMON_NAME_INVALID using new certificate

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:,,,

I ran this command: in Google Chrome browser

It produced this output: NET::ERR_CERT_COMMON_NAME_INVALID

My web server is (include version): Nginx 1.12.1

The operating system my web server runs on is (include version): Linux Ubuntu Server 16.04

My hosting provider, if applicable, is: Amazon AWS EC2 instance.

I can login to a root shell on my machine (yes or no, or I don’t know):yes.

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No.

Today unify a certificate with all the domains listed above, the domains and are working but the domains and are not working. send the error NET::ERR_CERT_COMMON_NAME_INVALID.

Thanks in advance for your attention.

Hola @carlosa.urrea,

The problem is with the redirects sent by your web server. and work fine and have a valid Let’s Encrypt certificate.

But and send redirects to which sends a redirect to which is invalid (your certificate does not cover your IP address and your site can’t be accessed by IP address using HTTPS).

This redirect behavior is probably a result of your nginx configuration. If you can find where it’s happening in your nginx configuration files, it should be possible to fix it so that nginx agrees to serve content directly on the HTTPS version of the site without generating additional unnecessary redirections.

You can watch this happen using curl -v from the command line, or using developer tools in a web browser (for example, if you press F12 in Firefox and then navigate to, you can see the series of redirections coming back from the server).

(By the way, the question about “I ran this command:” is trying to ask about what command you used in order to obtain and install the certificate.)

Hi Schoen,

You are right!

I’m going to review the Nginx configuration to solve the problem.

Thank you very much for your help.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.