Need to implement on oracle Application EBS suite 12.2.6 with 12c database


#1

Please fill out the fields below so we can help you better.

My domain is: Oracle applications (http://oar12apc.consolidated.work:8000)

I ran this command: Did not run any command

It produced this output: not applicable

My operating system is (include version): RHEL 7

My web server is (include version):

My hosting provider, if applicable, is: Not applicable

I can login to a root shell on my machine (yes or no, or I don’t know): Yes i have root ssh access

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):


#2

Hi @sudheer821

can you please explain the problem a bit more

I am assuming you are wanting to work LetsEcnrypt into a Oracle EBS application?

If so - have you done any research on how to configure EBS for SSL?
Do you have a plan of attack?
What are you looking for with assistance?

The fact you have not run any commands suggests to me you may not have done the groundwork??

Andrei


#3

have a read of this

i believe EBS is a java application so this may be relevant


#4

Hi Team,

The oracle EBS url is http://voar12a.consolidatedshoe.com:8000 – For the first time.

So i changed it back to http://voar12a.consolidatedshoe.com. So now i could able to connect using two links
http://voar12a.consolidatedshoe.com:80 and http://voar12a.consolidatedshoe.com.

I did the following::

  1. [root@voar12a /]# mkdir certbot
    [root@voar12a /]# cd certbot/
    [root@voar12a certbot]# wget https://dl.eff.org/certbot-auto

  2. [root@voar12a certbot]# ./certbot-auto

  3. SO the last output of the above lines are as follows::

Complete!
Creating virtual environment…
Installing Python packages…
Installation succeeded.
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Failed to find apache2ctl in PATH: /usr/lib64/qt-3.3/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/root/bin

  1. And i ran the following::

[root@voar12a certbot]# ./certbot-auto certonly --webroot -w /adfa/domains/voar12a/www/root -d voar12a.consolidatedshoe.com

  1. [root@voar12a certbot]# ./certbot-auto certonly --webroot -w /adfa/domains/voar12a/www/root -d consolidatedshoe.com
    Output of the above command::
    Saving debug log to /var/log/letsencrypt/letsencrypt.log
    Obtaining a new certificate
    Performing the following challenges:
    http-01 challenge for consolidatedshoe.com
    Using the webroot path /adfa/domains/voar12a/www/root for all unmatched domains.
    Waiting for verification…
    Cleaning up challenges
    Failed authorization procedure. consolidatedshoe.com (http-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: Could not connect to consolidatedshoe.com

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: consolidatedshoe.com
    Type: connection
    Detail: Could not connect to consolidatedshoe.com

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided

Please provide the resolution. Need to implement on Production.

Thanks,


#5

Hi Andrei,

I am assuming you are wanting to work LetsEcnrypt into a Oracle EBS application?
–> Yes because oracle charge for CA. where as LetsEncrypt provide the certificate for free and it is widely used by all.

If so - have you done any research on how to configure EBS for SSL?
Do you have a plan of attack?
What are you looking for with assistance?
–> My EBS url is http;//voar12a.consolidatedshoe.com:8000. I came to know that LE looks for http;//voar12a.consolidatedshoe.com (not the port). So i changed the EBS url from http;//voar12a.consolidatedshoe.com:8000 to http;//voar12a.consolidatedshoe.com.

Commands run?
My OS is RHEL 7, i ran the following and installed the rpms

a) [root@oar12apc apps]# mkdir certbot
[root@oar12apc apps]# cd certbot/
[root@oar12apc certbot]# ls
[root@oar12apc certbot]# wget https://dl.eff.org/certbot-auto
–2017-02-28 09:08:57-- https://dl.eff.org/certbot-auto

b) [root@oar12apc certbot]# ls
certbot-auto
[root@oar12apc certbot]# chmod a+x certbot-auto (given the permissions)
[root@oar12apc certbot]# ll
total 48
-rwxr-xr-x. 1 root root 46789 Feb 7 18:15 certbot-auto

c) [root@oar12apc certbot]# ./certbot-auto
Bootstrapping dependencies for RedHat-based OSes…
yum is /usr/bin/yum
Loaded plugins: amazon-id, rhui-lb, search-disabled-repos
Repodata is over 2 weeks old. Install yum-cron? Or run: yum makecache fast
rhui-REGION-client-config-server-7 | 2.9 kB 00:00
rhui-REGION-rhel-server-extras | 3.4 kB 00:00

…installed the RPM’s (packages)
…verified, upgraded, installed the dependencies

Installing Python packages…
Installation succeeded.
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Failed to find apachectl in PATH: /usr/lib64/qt-3.3/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/root/bin
Certbot doesn’t know how to automatically configure the web server on this system. However, it can still get a certificate for you. Please run “certbot-auto certonly” to do so. You’ll need to manually configure your web server to use the resulting certificate

d) [root@voar12a certbot]# ./certbot-auto certonly --webroot -w /adfa/domains/voar12a/www/root -d consolidatedshoe.com
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for consolidatedshoe.com
Using the webroot path /adfa/domains/voar12a/www/root for all unmatched domains.
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. consolidatedshoe.com (http-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: Could not connect to consolidatedshoe.com

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: consolidatedshoe.com
    Type: connection
    Detail: Could not connect to consolidatedshoe.com

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

–> ./certbot-auto certonly --webroot -w /adfa/domains/voar12a/www/root -d consolidatedshoe.com
/adfa/domains/voar12a/www/root – i created this directory structure. And got .Well-Known directory with empty got created.
As of now i am facing the above issue to get the certificate.

Please help

Thanks,


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.