Need help using LetsEncrypt manually

Hi all. I apologize for the fact that my question will be much more plebian than the average topic here. I’m not very good at this stuff. I’ve tried to figure it out all morning, reading the boards here and elsewhere, and have hit a wall.

The main problem stems from the fact that I want to use LetsEncrypt but host through Namecheap, which doesn’t support it yet. So I’m trying to do it manually, to see how that works for me before I debate changing hosters.

So for starters, My host web server runs apache, SSH is enabled, but my computer runs windows (not sure if that matters).

It seems one thing I could do, based on this website, is “run the certbot on your own computer manually”, but I couldn’t find an install file, I think because I’m running windows?

Another promising path seemed like the letsencrypt-win-simple that I downloaded from github. But I can’t get that to work either. I tried the FTP option, but that doesn’t work. It gives a huge error. The error started off with something like ‘unrecognized URI’, not sure what I did wrong, but now we’ve progressed to one with the detail “Error creating new authz: too many invalid authorizations recently”. So maybe that’s good, maybe I’ve made progress? But I’m not sure how to fix that, or what made the invalid authorizations. Does this program itself have a counter? I would think my previous errors so early in the process wouldn’t have flagged some sort of authorization counter, I don’t even think I was communicating with my website. One thought is that the process may have failed because the certificate being made by letsencrypt-win-simple is for servers running windows, as opposed to this exercise which is me running the exe on windows but a server running apache.

I also try the manual way, following this general command:
letsencrypt.exe --emailaddress --usedefaulttaskuser --accepttos --manualhost --webroot C:\random-local-folder-i-made

It does copy the convoluted filename to the random folder I made. And during the exe execution, it does pause for a while on ‘requesting authorization’ and then quickly closes after that, which I presume means that it finished without error? But then where would the certificate be for me to install to my live website? I can’t find it anywhere. My only thoughts are that I have no idea where to look. I’m also not sure whether it would even work, because my server runs apache, but I’m doing this on windows?

Anyways, sorry for the wall of low-brow text, I’d really appreciate help! Desperately want to get LetsEncrypt up and running!

Assuming that your hosting setup will let you install your own SSL certificate, probably the easiest thing to do is to use a web-based client like Nothing to install on your computer at all that way.


Thanks so much for the reply. That worked swell, I’ve got everything up and running fine. I might determine it’s a pain in the ass to do every 2 months, but we’ll see :slight_smile:

I’ll mark it as solved, if this board does something like that, but I’m still kind of irked I couldnt figure it out! Anyone have any ideas? obviously it’s not really pertinent anymore so don’t put too much thought into it. I’m usually good at figuring stuff like this out, even if its beyond my field of strength!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.