Need help instaling apache ubuntu 14.04


#1

Please fill out the fields below so we can help you better.

My domain is:billyiks.com

I ran this command:./certbot-auto

It produced this output: Domain: billyiks.com
Type: connection
Detail: Failed to connect to 184.168.221.22:443 for TLS-SNI-01
challenge

My operating system is (include version):14.04

My web server is (include version):

My hosting provider, if applicable, is:godady re directer to another ip

I can login to a root shell on my machine (yes or no, or I don’t know):yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):


#2

How are you redirecting things ? I suspect that’s the cause of your issue.

Try

./certbot-auto --preferred-challenges http-01

to use the http challenge which will redirect better in your case I suspect.


#3

root@Cobra:~# chmod a+x certbot-auto
root@Cobra:~# /certbot-auto --preferred-challenges http-01
-bash: /certbot-auto: No such file or directory
root@Cobra:~# ./certbot-auto
Saving debug log to /var/log/letsencrypt/letsencrypt.log
No names were found in your configuration files. Please enter in your domain
name(s) (comma and/or space separated) (Enter ‘c’ to cancel):billyiks.com
Enter email address (used for urgent renewal and security notices) (Enter ‘c’ to
cancel):cobra.tv@yahoo.com


Please read the Terms of Service at
https://letsencrypt.org/documents/LE-SA-v1.1.1-August-1-2016.pdf. You must agree
in order to register with the ACME server at
https://acme-v01.api.letsencrypt.org/directory

(A)gree/©ancel: a
Obtaining a new certificate
Performing the following challenges:
tls-sni-01 challenge for billyiks.com
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. billyiks.com (tls-sni-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: Failed to connect to 184.168.221.22:443 for TLS-SNI-01 challenge

IMPORTANT NOTES:

  • If you lose your account credentials, you can recover through
    e-mails sent to cobra.tv@yahoo.com.

  • The following errors were reported by the server:

    Domain: billyiks.com
    Type: connection
    Detail: Failed to connect to 184.168.221.22:443 for TLS-SNI-01
    challenge

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

  • Your account credentials have been saved in your Certbot
    configuration directory at /etc/letsencrypt. You should make a
    secure backup of this folder now. This configuration directory will
    also contain certificates and private keys obtained by Certbot so
    making regular backups of this folder is ideal.
    root@Cobra:~#

this what i gave me


#4

You missed the initial period off the command

./certbot-auto --preferred-challenges http-01

Note: it starts with a period - this means it triest to run the command (certbot-auto) in the current folder.


#5

root@Cobra:~# chmod a+x certbot-auto
root@Cobra:~# ./certbot-auto
Saving debug log to /var/log/letsencrypt/letsencrypt.log
No names were found in your configuration files. Please enter in your domain
name(s) (comma and/or space separated) (Enter ‘c’ to cancel):billyiks.com
Enter email address (used for urgent renewal and security notices) (Enter ‘c’ to
cancel):cobra.tv@yahoo.com


Please read the Terms of Service at
https://letsencrypt.org/documents/LE-SA-v1.1.1-August-1-2016.pdf. You must agree
in order to register with the ACME server at
https://acme-v01.api.letsencrypt.org/directory

(A)gree/©ancel: a
Obtaining a new certificate
Performing the following challenges:
tls-sni-01 challenge for billyiks.com
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. billyiks.com (tls-sni-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: Failed to connect to 184.168.221.22:443 for TLS-SNI-01 challenge

IMPORTANT NOTES:

  • If you lose your account credentials, you can recover through
    e-mails sent to cobra.tv@yahoo.com.

  • The following errors were reported by the server:

    Domain: billyiks.com
    Type: connection
    Detail: Failed to connect to 184.168.221.22:443 for TLS-SNI-01
    challenge

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

  • Your account credentials have been saved in your Certbot
    configuration directory at /etc/letsencrypt. You should make a
    secure backup of this folder now. This configuration directory will
    also contain certificates and private keys obtained by Certbot so
    making regular backups of this folder is ideal.
    root@Cobra:~#
    root@Cobra:~#
    root@Cobra:~#
    root@Cobra:~#
    root@Cobra:~#
    root@Cobra:~# ./certbot-auto --preferred-challenges http-01
    Saving debug log to /var/log/letsencrypt/letsencrypt.log
    No names were found in your configuration files. Please enter in your domain
    name(s) (comma and/or space separated) (Enter ‘c’ to cancel):billyiks.com
    Obtaining a new certificate
    Performing the following challenges:
    None of the preferred challenges are supported by the selected plugin
    root@Cobra:~#
    nothing worked


#6

how can i open port 443 might be that

this is the steps im using


can you give another step to see whats wrong


#7

Have you got a firewall that’s blocking port 443 ?

If not then running

sudo a2enmod ssl

and

sudo service apache2 restart

should enable https on ubuntu.


#8

no it did not work
can you check by TeamViewer my server ??


#9

Is certbot still giving the same error when run ?


#10

yes is still the same


#11

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.