Multiple SSL Sites on Same Server

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:
thenewjbar.com

I ran this command:
sudo certbot --apache

It produced this output:
Which names would you like to activate HTTPS for?


1: sigmasouth.com
2: www.sigmasouth.com
3: thenewjbar.com


Note: sigmasouth is working fine and has a valid certificate. I followed setting up letsencrypt for multiple Apache applications on the same server.

I choose 3 and Reattempt install
Here is the output:

File:

  • Could not be found to be deleted /etc/apache2/sites-available/thenewjbar-le-ssl.conf - Certbot probably shut down unexpectedly
    An unexpected error occurred:
    StopIteration
    Please see the logfiles in /var/log/letsencrypt for more details.

IMPORTANT NOTES:

  • Unable to install the certificate
  • Congratulations! Your certificate and chain have been saved at:
    /etc/letsencrypt/live/thenewjbar.com-0001/fullchain.pem
    Your key file has been saved at:
    /etc/letsencrypt/live/thenewjbar.com-0001/privkey.pem
    Your cert will expire on 2021-05-21. To obtain a new or tweaked
    version of this certificate in the future, simply run certbot again
    with the "certonly" option. To non-interactively renew all of
    your certificates, run "certbot renew"

My web server is (include version):
Server version: Apache/2.4.29 (Ubuntu)
Server built: 2020-08-12T21:33:25

The operating system my web server runs on is (include version):
Distributor ID: Ubuntu
Description: Ubuntu 18.04.5 LTS
Release: 18.04
Codename: bionic

My hosting provider, if applicable, is:
Self Hosted on an Ubuntu VM in Azure

I can login to a root shell on my machine (yes or no, or I don't know):
yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):
No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):
certbot 0.31.0

1 Like

Is there a question that needs answering?
Is there a problem that is preventing you from enjoying the benefits of a free and fully automated LE cert?
...
Or, are you just sharing your experiences / recent accomplishments?

OK I think I found what you are trying to resolve:

Let's have a look at the output of:
apachectl -S

1 Like
VirtualHost configuration:

*:443 www.sigmasouth.com (/etc/apache2/sites-enabled/sigmasouth-le-ssl.conf:2)
*:80 is a NameVirtualHost
default server www.sigmasouth.com (/etc/apache2/sites-enabled/sigmasouth.conf:4)
port 80 namevhost www.sigmasouth.com (/etc/apache2/sites-enabled/sigmasouth.conf:4)
port 80 namevhost thenewjbar.com (/etc/apache2/sites-enabled/thenewjbar.conf:1)
alias thenewjbar.com
wild alias *.thenewjbar.com
ServerRoot: "/etc/apache2"
Main DocumentRoot: "/var/www/html"
Main ErrorLog: "/var/log/apache2/error.log"
Mutex mpm-accept: using_defaults
Mutex watchdog-callback: using_defaults
Mutex rewrite-map: using_defaults
Mutex ssl-stapling-refresh: using_defaults
Mutex ssl-stapling: using_defaults
Mutex ssl-cache: using_defaults
Mutex default: dir="/var/run/apache2/" mechanism=default
PidFile: "/var/run/apache2/apache2.pid"
Define: DUMP_VHOSTS
Define: DUMP_RUN_CFG
User: name="www-data" id=33 not_used
Group: name="www-data" id=33 not_used

1 Like

Sorry for the missing information in my original post. I am able to secure one domain properly (sigmasouth.com) but run into issues when trying to secure other domains on the same server. Specifically I run into "unable to install the certificate" error below when trying to secure thenewjbar.com.

1 Like

Let's have a look at this file:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.