Moved server to new location and updated certs but all browsers still show them as expired?


#1

I moved my server to my new place. It had been offline a while and the certs expired so I installed new ones. But all my browsers still see expired certs, even after clearing ALL browsing data. Checking the certs the paths are correct in Apache config, they indeed point to the new certs that were just installed… I’m confused?

My domain is: hellhawks.net

I ran this command: sudo ./certbot/certbot-auto -d hellhawks.net -d *.hellhawks.net --manual --preferred-challenges dns-01 --server https://acme-v02.api.letsencrypt.org/directory certonly

My web server is (include version): Apache 2

The operating system my web server runs on is (include version): Ubuntu Xenial (Server Edition)

My hosting provider, if applicable, is: Myself

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No


#2

Please show:
sudo ./certbot/certbot-auto certificates


#3

Found the following certs:
Certificate Name: hellhawks.net
Domains: hellhawks.net *.hellhawks.net
Expiry Date: 2018-10-08 13:51:38+00:00 (VALID: 89 days)
Certificate Path: /etc/letsencrypt/live/hellhawks.net/fullchain.pem
Private Key Path: /etc/letsencrypt/live/hellhawks.net/privkey.pem


#4

Have you restarted Apache?
If so, then show the vhost config file.

It seems to be working now:


#5

(facepalm) It’s like wondering why the lawnmower won’t start, checking everything but the gas in the tank lol. Restarting Apache worked lol.


#6

Glad to have helped :slight_smile:
Be sure to include that step in your renewal process.


#7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.