MAMP 6.6.4 + macOS13.1 + SSL + FTP + DNS + MAIL

My domain is:

I ran this command: certbot renew

It produced this output:

My web server is (include version): macOS 13.1 Apple M1

The operating system my web server runs on is (include version): macOS 13.1

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

Hi all,

I was just updating my web running on Apple MacMini M1/8Gb RAM to macOS 13.1 running MAMP 6.6.4 (incl. latest BREW, XCODE...)

I have been able to get very high score in test on on my webside like and or around 80% ( get 73% need to fix SECDNS)
To get better score I just need to upgrade the connection to IPv6

All is fine except having small issues with my old emails linked to gmail and Apple iCloud so now I'm just using normal gmail while sorting out my mail problems.

In the old days I used a lot Kerio mail server (sold, now expensive), Icelandic DNS server (quit support for mac) and Rumpus FTP, WebDAV, and Web file-transfer server. Now I also want to include Filemaker Server. I was running this all on Macmini. Now I'm trying to rebuild similar system with the latest free software.

MAMP 6.6.4 is running fine but still small problems with Let´s Encrypt SSL like auto renew etc. would be nice to see Let´s Encrypt SSL setup incl. in next version MAMP 7.0.

If I run "certbot renew" then I get fllowing error:

The following error was encountered:
[Errno 13] Permission denied: '/var/log/letsencrypt/.certbot.lock'
Either run as root, or set --config-dir, --work-dir, and --logs-dir to writeable paths.
Ask for help or search for solutions at See the logfile /var/folders/q9/yrzvmrd16qg4krdsvh7gynb80000gn/T/certbot-log-1ooss7u4/log or re-run Certbot with -v for more details.

(so I just do manual renew).

So far I have been using those links for help to create new domain SSL on MAMP:

(would be nice to get update on this for Apple M1 macOS 13.1 and latest MAMP 6.6.4)

I have had good luck until now.

Now I try to run this command as usual for my latest new domain:

sudo certbot certonly --webroot -w /Users/shv/Sites/2-Work/ -d -d

All is working fine until I try link my MAMP SSL setup to the newly created SSL data.

Then files (cert.pem, chain.pem, privkey.pem, REDAME) disappear (except fullchain.pem) from the folder "arcive" when I select the last "chain.pem" plus I get RED alarm text on MAMP!

Any idea how to fix? Wold be also nice to get comment on good solution for free DNS, FTP, Mail server running on Mac M1




Certbot manages the directory /etc/letsencrypt, and stores the actual Certificates as versioned files under /etc/letsencrypt/archive/{CERTIFICATE_NAME}/, wherein CERTIFICATE_NAME is usually just the name of the first domain. The files are stored as chain1.pem, chain2.pem, etc. This numbering scheme repeats for all 4 filetypes (cert, chain, fullchain, privkey) associated with each certificate.

Certbot creates a symlink to the most recent active CERTIFICATE_NAME files under /etc/letsencrypt/active/{CERTIFICATE_NAME}. Under that directory you will see 4 unversioned file names: cert.pem, chain.pem, fullchain.pem and privkey.pem.

In your post above, "arcive" is obviously a typo. Since the file you mentioned is unversioned, you probably meant "active" and not "archive". Most likely,the active symlinks were removed during the failed upgrade process.

Running as root (sudo) should have fixed things. It is possible that your second run created a different CERTIFICATE_NAME, which is often just a versioned directory -- e.g. {CERTIFICATE_NAME}_001.

The Certbot log should disclose where the last certificates were installed. You can also invoke:

certbot certificates

Which will list all the certificates managed by Certbot and where they are located.

I hope the above helps you debug whatever is going on.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.