Dear Family,

Our server: Ubuntu 14.04
Control Panel: Vesta
Two domains installed by vesta with unique Let’s Encrypt certificates for each domain.
A single IP for both domains

Dear, we have installed Magento in the configuration above.

Magento has multiple domains configuration ok.

The main domain: has a perfect SSL certificate.

The secondary domain: is with the message of Not Secure.

We already have the certificate instantiated and tested on the server for both domains.

But after review by google inspect it shows that the certificate is not valid as it is showing the credentials of the primary domain (

I need help solving this problem.

I did not find google a solution.

Thank you in advance.

Best and Regards.


Hi @claudiobiato

what's your domain name? There are too much different errors possible, so we need to test some things.

You may use one of these tools:

yes, Not Secure:

Oh, there are a lot of errors.

Please check the output of

The good thing: The certificate is correct:
expires in 88 days, - 2 entries

Both domain names.

But the www-version doesn’t use that certificate, instead
expires in 50 days, - 2 entries

is used. So check your vHost, your vHost with as ServerName should have the www-version as ServerAlias.

Second: Ipv6 is defined (there are AAAA entries), but not configured.

ConnectFailure - Unable to connect to the remote server No connection could be made because the target machine actively refused it [2604:a880:800:10::5e0:3001]:443

Looks like a firewall. Are your vHosts with ipv6 configured?

Hello, Juergen Auer
Thank you for your help,
Since you sent the answer I’ve been trying but I can not solve it.
It’s very confusing for me, I have little programming knowledge.
The problem may be related to redirection in my domain.
Domain 2 is using all configuration, domain 1 folders and is being redirected by pulling the domain 1 certificate.
I added aliases, checked IPV6 enable in Digital Ocean, all ok, but not success.
I made some modifications and all the setup in Magento is according to the certificate that is working.
The redirection in .htacess and index.php is working perfectly.
But there is this conflict in displaying the correct certificate.
Maybe I have to go to site1.apache2.conf and site1.apache2.ssl.conf to post the SSL address of site 2.
Or maybe the problem is in the NGINX configuration.
Like I said, a lot of doubt where to start.
If you have any direction for me I’ll be grateful.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.