macOS is DEPRECATED!


#1

I’m trying to install Let’s Encrypt for the website that is on clousite hosting on liquidweb. I started following the steps here: https://help.liquidweb.com/s/article/Installingt-s-Encrypt-SSL-in-Cloud-Sites?name=Installingt-s-Encrypt-SSL-in-Cloud-Sites&fromCase=1

While trying to install certbot I went to https://certbot.eff.org/ and selected Apache on Web Hosting Service. I just ran certbot-auto in the terminal on my imac OSX v10.11.6 and recieved the warning below about macOS being depreciated. Liquidweb support wasn’t sure how to resolve the issue so I’m asking here in hopes that someone can direct me to the right way to install certbot. I’m not well versed in this so very specific instructions would be helpful.

My domain is: http://99buckswebdesign.com

I ran this command: I just ran certbot-auto in the terminal on my imac OSX v10.11.6

It produced this output: WARNING: certbot-auto support for this macOS is DEPRECATED!
Please visit certbot.eff.org to learn how to download a version of
Certbot that is packaged for your system. While an existing version
of certbot-auto may work currently, we have stopped supporting updating
system packages for your system. Please switch to a packaged version
as soon as possible.

My web server is (include version): liquidweb.com

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: liquidweb.com clousites

I can login to a root shell on my machine (yes or no, or I don’t know): yes


#2

Did you already followed up the advice as said in the warning message? I.e., go to certbot.eff.org and check the certbot instructions for MacOS? You’d find the following page: https://certbot.eff.org/lets-encrypt/osx-apache


#3

You appear to be running certbot on your local Mac computer, but you need to be running it on your cloud server at LiquidWeb in order to get a certificate for it.

LiquidWeb’s help portal should have a page with instructions for setting up SSH access and connecting to your server with the ssh command in the macOS Terminal. (Unfortunately their help documents are restricted to customers so I can’t find a link for you.)

Once you have connected to your server via SSH, then you can follow their instructions for installing and setting up certbot on your server.


#4

I talked to support again and they said this:
"This document should be used to configure certbot if you plan on using it on a mac:

Unfortunately root access is not possible on Cloudsites, only FTP access, In the documentation provided, it should specify a commandline to run it.

You may have to run that commandline using sudo, that’s true, and you should have those permissions on a mac."

I went through the steps again. I got down to the steps for entering the command to verify the certificate by adding TXT file to the DNS for my domain. This is the error that I’m getting though and I’ve double checked that the DNS settings are correct:

Waiting for verification…
Cleaning up challenges
Failed authorization procedure. www.99buckswebdesign.com (dns-01): urn:acme:error:dns :: DNS problem: NXDOMAIN looking up TXT for _acme-challenge.www.99buckswebdesign.com, 99buckswebdesign.com (dns-01): urn:acme:error:dns :: DNS problem: NXDOMAIN looking up TXT for _acme-challenge.99buckswebdesign.com

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: www.99buckswebdesign.com
    Type: None
    Detail: DNS problem: NXDOMAIN looking up TXT for
    _acme-challenge.www.99buckswebdesign.com

    Domain: 99buckswebdesign.com
    Type: None
    Detail: DNS problem: NXDOMAIN looking up TXT for
    _acme-challenge.99buckswebdesign.com

I’m not sure how to continue. Is it possible that I need to wait longer for the DNS to resolve before trying to verify? I’m just worried that the hash will expire


#5

The DNS still isn’t updated 4 hours later:

$ dig txt _acme-challenge.99buckswebdesign.com

; <<>> DiG 9.11.1-P3 <<>> txt _acme-challenge.99buckswebdesign.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 10175
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;_acme-challenge.99buckswebdesign.com. IN TXT

;; AUTHORITY SECTION:
99buckswebdesign.com.   1799    IN      SOA     ns73.domaincontrol.com. dns.jomax.net. 2018062509 28800 7200 604800 3600

;; Query time: 84 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Mon Jun 25 12:30:10 MST 2018
;; MSG SIZE  rcvd: 133

Can you share a screenshot of the screen where you entered the DNS records certbot asked you to? There’s probably just a simple mistake there somewhere.


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.