Linode - Let’s Encrypt SSL - how to do it?


I have hosting at Linode, and there I have installed Ubuntu 16.04 LTS, and then I have installed Wordpress

Now I want to use Let’s Encrypt SSL, and i have followed this tutorial:

I have done all steps, but still after that https is not working… :frowning:

What I need to do somethine else additionally in Wordpress or somewhere else ?

please help

Thank you

If you search wordpress on this forum there was someone with almost an identical problem as you yesterday.


hmmm… which one ?
there are several topics :frowning:

also my domain is:

why not scan them all :smiley:



I belive i am very close to solution

can you check my website now:

now https is working, but it is Forbidden ?

why ?

i used this:

<VirtualHost *:443>
DocumentRoot /srv/users/serverpilot/apps/wordpress/public
SSLEngine on
SSLCertificateFile /srv/users/serverpilot/apps/wordpress/letsencrypt/live/
SSLCertificateKeyFile /srv/users/serverpilot/apps/wordpress/letsencrypt/live/
SSLCertificateChainFile /srv/users/serverpilot/apps/wordpress/letsencrypt/live/

As Linode is a VPS service, they have completely no responsibility regarding the support of software on their platform; that is the total responsibility of the user.

It appears you are using Apache, so you must make sure all the rules you previously placed in your plaintext HTTP server configuration get moved to your HTTPS server configuration; the two are considered separate servers and thus must be configured individually.
Once you get the HTTPS server working, it would be a good idea to make the HTTP server redirect everything over to the HTTPS side. In addition, if your copy of Apache supports HTTP/2 (if it doesn’t the PPA at will upgrade your Apache to a version that does) it would be an excellent idea to enable it, as it will boost your site’s performance, possibly above that of plaintext HTTP.
Assuming you took the June 2016 memory upgrade, your Linode should be equipped with AES-NI, which provides AES encryption performance of over 1 gigabyte (not gigabit) per second, according to the “openssl speed” test, more if you have a multi-core Linode.

Thats why I asked for help here

Because I hope someone can help me

A quick port scan (see shows that port 443 is refusing connections. I have never used serverpilot before (so I’m not sure what their configuration is) but you may want to check and see if they install a firewall that may be blocking that port.

Most likely you are missing a Listen 443 directive in your Apache config.

Come to think of it, it probably is not a firewall issue but rather a config issue (as jsha said above). I took a quick look a the serverpilot website and it looks like they use a nginx proxy in front of Apache for their site configuration. This means you will need to configure nginx to handle ssl.

A quick Google search brought up this article:

1 Like

Thank you thank you :slight_smile:

it is working now :slight_smile:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.