Letsencrypt with cloudfare


Recently I just tried to create my certs for my site, which use cloudfare. I have tried serveral times without success, getting the next error:

- The following errors were reported by the server:

Domain: domain.com
Type: tls
Detail: Failed to connect to host for DVSNI challenge

To fix these errors, please make sure that your domain name was
entered correctly and the DNS A record(s) for that domain
contain(s) the right IP address. Additionally, please check that
you have an up-to-date TLS configuration that allows the server to
communicate with the Let’s Encrypt client.

finally, I deactivated cloudfare and worked without problems.

So, the question is, I’ll be able to renew my certs if I activate couldfare again? How it is supposed to work using cloudfare?


You are using a challenge type that's incompatible with CDN services such as CloudFlare. Take a look at this guide (written by a CloudFlare developer):

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.