LetsEncrypt in DirectAdmin with domain alias / pointer

My domain is: laurenscantorij.nl
It is run on a hosting with DirectAdmin, with automated LetsEncrypt Certs.

I managed to create a certificate for this domain and it works ok.

But… I added 5 domain pointers (as alias), from which the domain laurenscollegiumrotterdam.nl is one of them. I want to create a new certificate which include the primary, but also all secondary domains.
When I then create this certificate in DirectAdmin, I can select these secondary domains in the list of Let’s Encrypt Certificate Entries.
However when I try to create this certificate, it gives an error for the first of the secondary domain:

Getting challenge for laurenscantorij.nl from acme-server…
Waiting for domain verification…
Challenge is valid.
Getting challenge for laurenscollegiumrotterdam.nl from acme-server…
Waiting for domain verification…
Challenge is invalid. Details: DNS problem: SERVFAIL looking up A for laurenscollegiumrotterdam.nl. Exiting…

The same response I get when selecting one of the other secondary domains.
As far as I can see, there is a normal entry for A in the DNS of the secondary laurenscollegiumrotterdam.nl.

Can you please help me out on this?

Found it out myself.
I was impatient and tried to create the certificates inside DNS propagation time.

24 hours later it worked properly…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.