Letsencrypt error occured!


Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: api.latte.ai

I ran this command: certbot

It produced this output:

certbot: error: unrecognized arguments: --private-key-owner root --private-key-group ssl-cert --private-key-permission 640

My web server is (include version): nginx

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: AWS route53

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no


Hi @sbqsbqsbq,

How did you install Certbot? Did you ever specify these options about the file permissions anywhere in your configuration or in the commands that you ran?


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.