Letsencrypt-auto works before, but it got something wrong recently


#1

Please fill out the fields below so we can help you better.

My domain is:
develop.cloudpe.com

I ran this command:
sudo ./letsencrypt-auto --standalone --standalone-supported-challenges tls-sni-01 -d $NEW_DN certonly --config $config_file

or

sudo ./letsencrypt-auto --webroot -w /var/www/bigbluebutton-default/ -d $NEW_DN certonly --config $config_file

It produced this output:
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
python-dev : Depends: libpython-dev (= 2.7.5-5ubuntu3) but it is not going to be installed
Depends: python2.7-dev (>= 2.7.5-1~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

My operating system is (include version):
Ubuntu 14.04.3 LTS

My web server is (include version):
nginx/1.4.6 (Ubuntu)

My hosting provider, if applicable, is:
our own server, not virtual machine

I can login to a root shell on my machine (yes or no, or I don’t know):
yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
no

The tool “letsencrypt-auto” we used before(one or two month ago) is working but recently, we got error message mentioned above when using the same command on the same server. I thought that’s the python dependence issue but not sure. Could you help us to resolve this or provide your suggestion? Thanks in advance.


#2

The problem is the " Unable to correct problems, you have held broken packages."
try

sudo apt-get update

which should update the package list

sudo apt-get upgrade

which should upgrade the packages on your ubuntu.

It will probably be useful to run

dpkg --get-selections | grep hold

to see what the held broken packages are as well.


#3

Hi
Thanks for you reply

result of running on our server

firstuser@meet4testvm:~$ sudo apt-get update
Ign http://us.archive.ubuntu.com trusty InRelease
Hit http://ubuntu.bigbluebutton.org bigbluebutton-trusty InRelease
Ign http://downloads-distro.mongodb.org dist InRelease
Ign http://ppa.launchpad.net trusty InRelease

Hit http://us.archive.ubuntu.com trusty/universe Translation-en
Ign http://us.archive.ubuntu.com trusty/main Translation-en_US
Ign http://us.archive.ubuntu.com trusty/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com trusty/restricted Translation-en_US
Ign http://us.archive.ubuntu.com trusty/universe Translation-en_US
Fetched 5,391 kB in 18s (285 kB/s)
Reading package lists… Done

it looks good~

firstuser@meet4testvm:~$ sudo apt-get upgrade
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done
The following packages have been kept back:
bind9-host cpp-4.8 curl dbus dbus-x11 dnsmasq-base dnsutils eog file-roller

Preparing to unpack …/bbb-record-core_0.9.0-1ubuntu44_amd64.deb …
/etc/init.d/bbb-record-core: line 29: kill: (31460) - No such process
invoke-rc.d: initscript bbb-record-core, action “stop” failed.
dpkg: warning: subprocess old pre-removal script returned error exit status 1
dpkg: trying script from the new package instead …
/etc/init.d/bbb-record-core: line 29: kill: (31460) - No such process
invoke-rc.d: initscript bbb-record-core, action “stop” failed.
dpkg: error processing archive /var/cache/apt/archives/bbb-record-core_0.9.0-1ubuntu44_amd64.deb (–unpack):
subprocess new pre-removal script returned error exit status 1
God started
Errors were encountered while processing:
/var/cache/apt/archives/bbb-record-core_0.9.0-1ubuntu44_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

the upgrade procedure seems not to be complete, but I’m not sure if that’s the reason.

firstuser@meet4testvm:~$ dpkg --get-selections | grep hold

that returns nothing


#4

This looks to be an issue with BigBlueButton (an open source web conferencing system for on-line learning ) Is this a package / system you still use ? if not then the easiest option may be to remove it. If it is something you use, then best to try and repair that failed package.


#5

Then I want to avoid the problem package, so I mark it

firstuser@meet4testvm:~$ sudo apt-mark hold bbb-record-core
firstuser@meet4testvm:~$ sudo apt-get upgrade
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done
The following packages have been kept back:
bbb-record-core bind9-host cpp-4.8 curl dbus dbus-x11 dnsmasq-base dnsutils
eog file-roller firefox g+±4.8 gcc-4.8 gcc-4.8-base gcc-4.8-base:i386

Removing debian:UTN_DATACorp_SGC_Root_CA.pem
Removing debian:Verisign_Class_4_Public_Primary_Certification_Authority_-_G3.pem
Removing debian:spi-cacert-2008.pem
Removing debian:SG_TRUST_SERVICES_RACINE.pem
done.
done.

it looks good after mark

firstuser@meet4testvm:~$ dpkg --get-selections | grep hold
bbb-record-core hold

Is that the reason why we got the dependence issue after running letsencrypt tool?

Thanks in advance!!


#6

Yes, it all relates back to that package, which was causing the update issues. If you try letsencrypt now it will hopefully upgrade the relevant packages.


#7

Thanks for your help. I will check this.


#8

I have a problem I can’t install let’s encrypt by GIT , root@swissscloud:/# git clone https://github.com/letsencrypt/letsencrypt /opt/letsencrypt --depth=1
Cloning into ‘/opt/letsencrypt’…
fatal: unable to access ‘https://github.com/letsencrypt/letsencrypt/’: Problem with the SSL CA cert (path? access rights?)


#9

This looks to be a completely different issue / error. Please open a new thread, and provide a little more info ( operating system, version etc )


#10

Hi,

your command works for me. I don’t know what happened.I am not the expert, maybe you can check your git config?


#11

I am on debian 8.6 , im up to date with git , its a vps on Proxmox like a container


#12

what can i do with my git config ?


#13

@Ermal1 - this thread is resolved. I’m going to mark it closed for further replies. Please open a new thread with your question and ensure you fill out the information it asks you about your server & software versions so that someone will be able to help you straight-away. Thanks!


#14