Let's Encypt on Univention Server


#1

Hi,

I’ve tried using the Let’s Encrypt Applciation on our Univention Server. When I have Added the domain of our Univention the certificate worked, but when I’m trying to add another domain name for another server I’m getting this error.

Status

Current status of the App

ValueError: Challenge did not pass for prtg.sav25.com: {u’status’: u’invalid’, u’challenges’: [{u’status’: u’invalid’, u’url’: u’https://acme-v02.api.letsencrypt.org/acme/challenge/MOSCnPVALYoZpiNLjMOWeinJsWq5xtXvjVeErV-kIe8/7128929791’, u’token’: u’0iozqFx8qPOoEWVmu3OSo_96Qc6CeFOHg0vZvdRP2cM’, u’type’: u’dns-01’}, {u’status’: u’invalid’, u’validationRecord’: [{u’url’: u’http://prtg.sav25.com/.well-known/acme-challenge/EJCgJZXWZeT_-UMs1Gi0maW4pnIxOjwKTBKAeK5rEeA’, u’hostname’: u’prtg.sav25.com’, u’addressUsed’: u’203.160.181.90’, u’port’: u’80’, u’addressesResolved’: [u’203.160.181.90’]}, {u’url’: u’https://prtg.sav25.com/[https://prtg.sav25.com/.well-known/acme-challenge/EJCgJZXWZeT_-UMs1Gi0maW4pnIxOjwKTBKAeK5rEeA’, u’hostname’: u’prtg.sav25.com’, u’addressUsed’: u’203.160.181.90’, u’port’: u’443’, u’addressesResolved’: [u’203.160.181.90’]}], u’url’: u’https://acme-v02.api.letsencrypt.org/acme/challenge/MOSCnPVALYoZpiNLjMOWeinJsWq5xtXvjVeErV-kIe8/7128929792’, u’token’: u’EJCgJZXWZeT_-UMs1Gi0maW4pnIxOjwKTBKAeK5rEeA’, u’error’: {u’status’: 403, u’type’: u’urn:ietf:params:acme:error:unauthorized’, u’detail’: u’Invalid response from http://prtg.sav25.com/.well-known/acme-challenge/EJCgJZXWZeT_-UMs1Gi0maW4pnIxOjwKTBKAeK5rEeA: "\n\n\n\n

Not Found

\n

Is it not possible to use the Let’s encrypt app on other domains than the Univention Server?
Thank You.


#2

Hi,

Although I’m not familiar with univention server, I could see what’s going on with your site (second site)

You have a incorrect setup of redirect rules… (from http to https)
When let’s encrypt validation server visited your site at http… The server copy the whole link and add it to the https site…

E.G. if I connects to prtg.sav25.com/1, the site rewrites me to https://prtg.sav25.com/[https://prtg.sav25.com/1]

Please check your rewrite syntax…

Thank you


#3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.