Let's Encrypt SSL Certificate Not Showing on Websites

This is my first time installing SSL Certificates. I’ve recently made the change from shared hosting (Hostgator) to VPS (InmotionHosting). Since requiring SSL certificates for multiple domains, I installed The Let’s Encrypt Plugin on my server with Manage AutoSSL https://gyazo.com/4fd37ffe14e258338d80b12839e179d0 unfortunately I can’t seem to understand, why Let’s Encrypt SSL doesn’t show up on my domains.

My domain is: DetroitCityHomes.com

I ran this command:

It produced this output:

My web server is (include version): Inmotionhosting VPS

The operating system my web server runs on is (include version): CENTOS 7.4 virtuozzo

My hosting provider, if applicable, is: Inmotionhsoting

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Yes

The domain is reachable via https but you seem to be putting cloudflare in front of your vps.
Try searching the community for cloudflare.

I’ve turned off Cloudflare SSL for that domain. I’m assuming that should prevent Cloudflare from overriding my server SSL, therefore enabling Let’s Encrypt SSL to show on my domains. In addition, do you think I should consider enabling “Always use HTTPS Redirect all requests with scheme “http” to “https”. This applies to all http requests to the zone”

As long as Cloudflare is in front of your website, you cannot use a locally generated certificate. If you disable Cloudflare-SSL only, you are just breaking https for your domain name but it stays in front.

review Using CloudFlare with Let's Encrypt With CloudFlare - Issues with Reverse Proxying

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.