Lets Encrypt on amazon web services RHEL


#1

Hi All,

When running the client on a RHEL instance running on EC2 i get the following error:
Error: Package: python-pip-7.1.0-1.el6.noarch (epel)
Requires: python(abi) = 2.6
Installed: python-2.7.5-34.el7.x86_64 (@anaconda/7.2)
python(abi) = 2.7
python(abi) = 2.7
Available: python-2.7.5-16.el7.x86_64 (rhui-REGION-rhel-server-releases)
python(abi) = 2.7
python(abi) = 2.7
Available: python-2.7.5-18.el7_1.1.x86_64 (rhui-REGION-rhel-server-releases)
python(abi) = 2.7
python(abi) = 2.7

I have tried installing a python 2.7 version of pip and using python 2.6 but it looks like these versions are engrained in the install.

Any suggestions would be very much appricated!


#2

The client is packaged in EPEL, so I’d recommend using the packaged version there unless you need some special feature only in the latest bleeding-edge code.


#3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.