Let's Encrypt not working in Malaysia

Hey everyone

We installed LE certificate for one of our clients based in Malaysia and it didn’t work for them, it worked fine in Europe. We then bought and installed a new certificate and it works fine everywhere.

Would anyone know why that happened? Is it due to their ISP?

Hi @umarsheikh,

That's pretty strange! Let's Encrypt certificates should work as well in Malaysia as anywhere.

Can you share the domain name(s) that the certificate was issued for?
Can the client provide more information about how it failed for them? Ideally a screenshot of the error & if possible the certificate that was presented to the browser. It would also be helpful to know more about the browser and client operating system versions.

Usually this kind of thing is caused by a missing intermediate in the server configuration or a hostname mismatch. Occasionally it can be caused by an ISP or piece of networking gear doing traffic inspection.


Indeed, we’ve issued about 55,000 certificates to .my domain names (as well as other sites in Malaysia that use other top-level domains)


I just tried a couple of the names that we issued certificates to today, and they worked fine with HTTPS.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.