Let's Encrypt certificate expiration notice "mydomain.net"

Hello, last day i received notice from you, how can i fixed this issue i try to
run sudo certbot renew and resulted to this error bash renewal command not found
what will i do or step by step command i use to fix this thanks very much more power

Your certificate (or certificates) for the names listed below will expire in
10 days (on 02 Feb 18 07:57 +0000). Please make sure to renew
your certificate before then, or visitors to your website will encounter errors.


Please provide the information requested.

In particular, what the domain is, what command was run, exactly what the error message is, and also what command was used to create the certificate before.

Additionally, the unsubscribe link in your post could be used by you or anyone else to irrevocably unsubscribe your email address from all certificate expiration notices. I’ve removed it from your post, but it’s possible someone has already clicked it, and the old version of the post has probably been archived in places. If the address has been – or will be – unsubscribed, the only option is to switch to a different email address. :sweat: (Of course, many providers support different address aliases for the same email account, like user+123@example.com.)

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

Oh sorry for that, thank you Sir Matt Nordhoff for urgent rply, below
are the information

My domain is: https://rtsc.ddns.net

I ran this command: sudo certbot renew

It produced this output: bash renewal command not found

My web server is (include version):Apache

The operating system my web server runs on is (include version):Linux,
Debian 8.9 Jessie

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know): YES

I’m using a control panel to manage my site (no, or provide the name and
version of the control panel):NO

How did you originally obtain your certificate? Did you perhaps use certbot-auto or something?

hello sir Seth Schoen, yes sir i run ./certbot-auto… my understanding here sir it will automatically renew my certificate everytime it will expires, but last day i received an email notifying me that my certificate will expires on 10days how is that,?? my question is do i need to manually renew my certificate, if so how? and what are the commands to used? thanks sir more power…

Are you sure that “rtsc.ddns.net” is the real domain name? There doesn’t seem to have been a Let’s Encrypt certificate ever issued for that name, and that site doesn’t currently seem to exist at all.

sir can i have your email, so that we can chat on private thanks

It’s my forum username at eff.org.

sir can you email me at armrhod.presto.pnp@gmail.com

OK, you’ve sent me the real domain name by e-mail. That domain does exist and does have a certificate which is going to expire tomorrow.

It looks like you might not have automated renewal set up via cron on your server, or else the renewal might be getting attempted but failing. Can you run ./certbot-auto renew and see what output you get from that? It should either perform the renewal or give a more detailed explanation of why it’s failing.

Also, is that server consistently online and reachable from the Internet? I tried connecting to it on port 80, port 443, and via ping, and I didn’t see anything reply to me.

Ok sir pls try it again the server is on now

That looks fine, but the error message that you sent me by e-mail indicates that your server can’t connect to the Let’s Encrypt CA API at https://acme-v01.api.letsencrypt.org/directory. Are you on a network with some kind of firewall that limits outbound HTTPS connections?

If not, could you post the output of these commands?

host acme-v01.api.letsencrypt.org
curl -4 https://acme-v01.api.letsencrypt.org/directory
curl -6 https://acme-v01.api.letsencrypt.org/directory

Sir the outputs of the command is this

about firewall that limits outbound HTTPS connections? Im not sure about
that sir

It looks like the DNS resolver configuration on your server is broken. Can you resolve other hosts there? Like

host www.google.com
curl https://www.google.com/ | wc -c

here is the output sir, its mean sir that my server is not getting
outbound connection even if i ping google.com sir the rply is unknown

Yes, something seems to be wrong in the DNS resolver configuration on your server. It can’t find the IP addresses of any other servers from their domain names. This is necessary in order to make many kinds of outbound connections from your server. (Another example would be updating the operating system packages on the server, which is probably broken too at the moment.)

In principle, your server needs to be able to do DNS lookups in order to use Let’s Encrypt. It currently can’t, so your server is misconfigured in an important way that has nothing to do with us or our software.

Alternatively, you could put the line acme-v01.api.letsencrypt.org

into your /etc/hosts file, but this will not fix the underlying problem and may stop working at some point if our CDN stops using that IP address.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.