Lack of DNS Records Prevent Certbot From Issuing Certificates


#1

Please fill out the fields below so we can help you better.

My domain is:
www.omegainfo.idv.tw

I ran this command:
sudo certbot --apache

It produced this output:
Failed authorization procedure. www.omegainfo.idv.tw (tls-sni-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: DNS problem: SERVFAIL looking up A for www.omegainfo.idv.tw

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: www.omegainfo.idv.tw
    Type: connection
    Detail: DNS problem: SERVFAIL looking up A for www.omegainfo.idv.tw

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

My operating system is (include version):
Ubuntu 16.04

My web server is (include version):
Apache 2.4.18

My hosting provider, if applicable, is:
myself

I can login to a root shell on my machine (yes or no, or I don’t know):
yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
no


#2

You have errors in your DNS - see http://dnsviz.net/d/www.omegainfo.idv.tw/dnssec/


#3

Thank you for quick reply.
Actually my DNS record is managed by TWNIC(http://www.twnic.net.tw/ http://www.twnic.net.tw/), and I know little about DNS configurations.
How do you think if I provide the DNS error output and the following link you sent me, then the DNS administrator of TWNIC should have enough information to fix the error?

Best Regards.

Andy Beckett letsencrypt@discoursemail.com 於 2017年4月8日 下午11:00 寫道:

serverco https://community.letsencrypt.org/users/serverco Community Moderator
April 8
You have errors in your DNS - see http://dnsviz.net/d/www.omegainfo.idv.tw/dnssec/ http://dnsviz.net/d/www.omegainfo.idv.tw/dnssec/
Visit Topic https://community.letsencrypt.org/t/fail-to-apply-certificates-with-certbot/31661/2 or reply to this email to respond.

To unsubscribe from these emails, click here https://community.letsencrypt.org/email/unsubscribe/f16168694937831e2edbca3caa3d235df6dd2443feeef00ec1606af1a43fdfe6.


#4

Yes, they should be able to correct it for you.


#5

Thanks!

Andy Beckett letsencrypt@discoursemail.com 於 2017年4月8日 下午11:48 寫道:

serverco https://community.letsencrypt.org/users/serverco Community Moderator
April 8
Yes, they should be able to correct it for you.

Visit Topic https://community.letsencrypt.org/t/fail-to-apply-certificates-with-certbot/31661/4 or reply to this email to respond.

To unsubscribe from these emails, click here https://community.letsencrypt.org/email/unsubscribe/ebbab7bfa711773e77a96131f2cb668e0330f899ce510f05f37969d8dc4d167f.


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.