Kelunik implementation


#1

https://pastebin.com/imc9D2dw
These are the instructions as follows, supplied by my unsupportive reseller, Though I followed them to the T and successfully generated and installed an ssl certificate, I am having issues with a client’s account, hosted on the same machine.

The home directories seem isolated, so I can’t log into the admin account and access their files, so I have to obviously log in to the client’s account, which isn’t good practice…

but that’s not my issue. setup goes without a hitch, but nothing happens while registering, or while trying to issue it.
just blank output.

anyone else use kelunik’s implementation, and know anything about it?
I can’t use certbot because it’s shared hosting, so no Su access.


#2

It’s going to be hard to know what’s happening without some verbose logs or even an strace of what the process is doing.

Not much help to you, but I can suggest to check acme.sh out, it’s a very popular ACME client that also works without root access.

Since the client is working for other domains, it would help to also know what the actual domain you’re having problems with is.


#3

Sorry, it’s been awhile since I’ve really had trouble woth anything, it didn’t occur to me
to provide a log hold please


#4

[carnivalfunfair@bh-71 ~]$ cd acme-client
[carnivalfunfair@bh-71 acme-client]$ php bin/acme --verbose setup --server letsencrypt --email carnival-funfair.blog
[carnivalfunfair@bh-71 acme-client]$ php bin/acme --help
[carnivalfunfair@bh-71 acme-client]$

the domain that worked was thehost.ninja and the domain that i’m having an issue with is carnival-funfair.blog

Is there any other way to get the log without verbose flag? the binary doesn’t seem to be doing anything in actuality


#5
head -n 1 bin/acme
strace -fff -tt php bin/acme --help 2>&1 | tee -a strace.log
php --version

Try also compare php --version against the account that succeeded.

Different accounts in cPanel can often be running under different PHP versions, subject to CloudLinux’s PHP Selector or other version switching mechanisms.


#6

… that php version is way low, you are definitely onto something I think.

here’s entire output
https://pastebin.com/5AZeRMnV


#7

Hi,

Does your hosting allow you to run bash, sh or dash scripts?

If so, you can try to use acme.sh (Doesn’t need sudo use)

Also, there is a list of clients you can use to obtain an certificate.

Some of them can be used without sudo access.

Thank you


#8

Thanks for the strace. The file not found errors are fine, it’s just searching the library paths for the shared libraries it needs for each loaded PHP module.

The low PHP version is 100% the issue (unless you forgot to run composer install!). You can find the exact error in the error_log file

find . -type -f -name error_log

but it will probably be a syntax error or some non-forwards-compatible usage of a feature from PHP 5.6/7 etc.

Login to cPanel and see if you can switch the PHP version over, or if this would break the site, use acme.sh as suggested.


#9

Expanding @_az’s response:

From your log, It seems that there are too many “No such file or directory”…

Also, the PHP version of your hosting account (This account) is PHP 5.4.45

The required version is PHP 5.5+ with OpenSSL (Via https://github.com/kelunik/acme-client)

Try change your PHP version from cPanel to a higher version could work…

Thank you


#10

I changed php to 7.1 but php --version indicates I’m still running 5.4 in shell… how to reload it?


#11

Your shell version (which is server’s PHP version) is different from PHP version on your account. (I’m kind of confused since if you and the client are on the same server, the PHP default version can’t be different…)

Please follow this tutorial and change the shell php version.

https://www.inmotionhosting.com/support/community-support/general-server-setup/how-do-i-change-php-version-in-shell

Thank you

P.S. The server PHP is really old… The host should consider update it… lol


#12

It’s funny, cause I thought I was getting a great deal going through bluehost’s recommended reseller… =/
will try that and report back.


#13

Did you try logging out and into the shell again?

The version used by the web server may also be found in another directory (like /opt/php or something), you can often reveal where it is using phpinfo:

<?php phpinfo(); ?>

and accessing it in a browser.


#14

Shell use different PHP version (System PHP version) than the version cPanel uses…

@THErootUSER Here’s a much better (Detailed) instruction to change PHP version on Shell (Although it’s the same instruction)


#15

[carnivalfunfair@bh-71 ~]$ php --version
PHP 5.4.45 (cli) (built: Apr 29 2018 16:03:38)
Copyright © 1997-2014 The PHP Group
Zend Engine v2.4.0, Copyright © 1998-2014 Zend Technologies
with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v10.2.0, Copyright © 2002-2018, by ionCube Ltd.
with SourceGuardian v11.2, Copyright © 2000-2018, by SourceGuardian Ltd.
with Zend Guard Loader v3.3, Copyright © 1998-2013, by Zend Technologies
[carnivalfunfair@bh-71 ~]$ whereis php
php: /usr/bin/php /usr/lib/php.ini /usr/local/bin/php /usr/local/lib/php.ini /usr/local/lib/php /usr/local/lib/php.ini,v /usr/local/php
[carnivalfunfair@bh-71 ~]$ exit
logout
Connection to carnival-funfair.blog closed.

C:\Users\jase>ssh thehoqfk@thehost.ninja
Password:
[thehoqfk@bh-71 ~]$ php --version
PHP 7.1.17 (cli) (built: Apr 26 2018 16:12:59) ( NTS )
Copyright © 1997-2018 The PHP Group
Zend Engine v3.1.0, Copyright © 1998-2018 Zend Technologies
with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v10.2.0, Copyright © 2002-2018, by ionCube Ltd.
[thehoqfk@bh-71 ~]$

I dunno… I changed php to 7.1 on primary account before doing this since whmcs required it… i can’t see any other phps present,

I’m just going to try acme.sh though i do thank y’all for the help, this is let’s encrypt’s forum not jason’s php troubles, I tried exporting path like that dream host suggested too, but to no avail. So no point squandering your valuable time.

if i have an issue with that then i’ll surrender to nothing heh


#16

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.