Issues when paste account key

My domain is: yunasch.ml

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: InfinityFree

I can login to a root shell on my machine (yes or no, or I don’t know): IDK

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): cPanel (i think)

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): IDK

I was trying to install the ZeroSSL (from web client) certificate vía DNS and the dns records worked fine. Now, at the time I tried to upload the keys, InifnityFree says that doesn’t support keys bigger than 2048 bits. So I was wondering how do I specify create the Private Key in 2048 bits to make sure the keys and certificates upload successfully and finally get my SSL/TLS encryption for my web.

Thank you so much in advance!

Hi @yunasch

if you use ZeroSSL, check, if there is an option to define the size of the key.

If not: Do you have a cPanel with an integrated solution?

There

is an explantation: You can use the tool of your hoster to create a CSR.

That should have the correct key. Then you can upload that CSR using ZeroSSL.

1 Like

On ZeroSSL from web doesn’t let change the file size.
When I try to generate the key nothing happens on Infinity Free.

account key is just for acme protocal itself, signed certificate has different key. why are you try to upload acme account key to hosting?

It does, and it is documented - see the "Important" notice and the paragraph above it of the "How to use" section. Effectively you just need to use CSR Generator first and choose 2048 bits key, and then use that CSR with the SSL Certificate Wizard. Please note that the key generated by the CSR Generator will be your "domain key" - there will be no key shown at the last step of the SSL Certicate Wizard in this case.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.