Issues running certbot command

My domain is:

I ran this command:
sudo certbot --nginx

It produced this output:
jq: error (at :0): Cannot iterate over null (null)

My web server is (include version):
Hosted through AWS

The operating system my web server runs on is (include version):
Ubuntu v16.04

My hosting provider, if applicable, is:
Domain is currently hosted through Bluehost, but that will soon be moved to AWS.

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
I am currently connecting to my site’s server using SSH.

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):
Cannot run this command either.

I have tried removing and reinstalling Certbot using snap, but that did not fix the issue. I was able to get Certbot to run on another site without seeing this issue. I cannot figure out what the difference is.


Hi @gariepyt,

That’s an unfortunate issue which is my fault, but hopefully we will get it fixed soon. For now, try this:

sudo snap install core && sudo snap refresh core

That’s all you should need to do to fix it. Having an up-to-date snapd package from apt would also fix it for Ubuntu 16.04.

By the way, if anybody else runs into this in the next week or so, and you haven’t run the above command yet, it’d be great if you could also post what your OS is and the output of snap version.


To be clear, my current understanding is that while it may technically be true that the fact you see the exact error text

 jq: error (at :0): Cannot iterate over null (null)

is partially az’s fault, this problem occurring if core/snapd wasn’t updated existed before az made any changes and their changes improved a number of other things in the Certbot snap.


Welcome to the Let’s Encrypt Community :slightly_smiling_face:

Backward day has officially been accomplished.

If only we just started with solutions then worked backwards to the greeting. Where’s the fun in that though? :thinking:

1 Like

That did it. Thanks!!


Thanks, still work for me, my system is Ubuntu 18.04

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.