Certbot installation help

My domain is: reefmc.com

I ran this command: sudo snap install --classic certbot

It produced this output:
error: cannot perform the following tasks:

  • Run configure hook of "certbot" snap if present (run hook "configure": / has 'other' write 40777)

My web server is (include version): Apache/2.4.41 (Ubuntu)

The operating system my web server runs on is (include version): Ubuntu 20.04 LTS

My hosting provider, if applicable, is: n/a

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): not installed yet

I tried googling this error which brought me to a few threads, one from this site, that recommended checking the permissions of the /var folder, and after users changed them to 0755 they reported that it would work. The problem is, as far as I can tell, my /var folder is already 0755 and i've even tried doing sudo chmod 0755 /var to no avail. Still produced that error after running the chmod

Thanks for reading :slight_smile:


I think that's almost the solution, but not quite.

The error is complaining that your root directory (/) is insecure because it is world-writable (0777), rather than /var.

On a normal Linux system, it's writable only by the owner.

So, you could try:

sudo chmod o-w /

it might also be necessary to remove the group write:

sudo chmod g-w /

This was the solution for me. Thanks a ton!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.