How should I solve this error?

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: superboy.co.in

I ran this command: install snapd, and sudo install --classic certbot

It produced this output:

error: cannot perform the following tasks:

  • Run configure hook of “certbot” snap if present (run hook “configure”: /var has ‘other’ write 40777)

My web server is (include version):

The operating system my web server runs on is (include version): ubuntu 18.04

My hosting provider, if applicable, is: aws

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

2 Likes

What’s the mode of your /var directory?

stat var

It should be 0755.

If it’s 0777, snap is probably refusing to install anything because it’s a dangerous mode.

2 Likes

it’s in 0777
should I change it to the 0755?

Yes, probably.

Do you remember why you changed it to 0777 to begin with?

1 Like

I changed it to 0755 and certificate is installed but the https is not working

1 Like

What command did you use to install the certificate?

1 Like

Hi @saiteja

that’s not your domain, that domain isn’t registered - https://check-your-website.server-daten.de/?q=superbly.co.in

Host Type IP-Address is auth. ∑ Queries ∑ Timeout
superbly.co.in Name Error yes 1 0
www.superbly.co.in Name Error yes 1 0
*.superbly.co.in A Name Error yes
AAAA Name Error yes
CNAME Name Error yes

No name server, no SOA.

So you can’t create a certificate with that domain name. First - you need a domain name.

Start there:

Then: Installation of a client is only the first step. You have to use that client = create a certificate.

1 Like

That was a spelling mistake, it is superboy.co.in
I solved the error and installed the certificate now it is working
Thanks

1 Like

Thanks for the help I solved my error
Now it is working
Thanks and cheers

1 Like

Just as a general point, it is better if you use a more informative title on a post.

You could do with having a read of

How To Ask Questions The Smart Way

http://www.catb.org/~esr/faqs/smart-questions.html

Dave

2 Likes