Ispconfig install detects nginx but apache installed

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: tlwebservices - specifically hostname/domain name.. panel.tlwebservices.co.uk

I ran this command:
Install ispconfig using their new auto script on debian 10. My issue is when the installer detects (wrongly) that nginx is installed, but it isnt... it is apache installed and no nginx exists.. anywhere.

It produced this output: a portion i captured while trying to generate lets encrypt cert
[Mon 9 Aug 16:52:23 BST 2021] code='200'
[Mon 9 Aug 16:52:23 BST 2021] original='{
"type": "http-01",
"status": "invalid",
"error": {
"type": "urn:ietf:params:acme:error:connection",
"detail": "Fetching http://panel.tlwebservices.co.uk/.well-known/acme-challenge/crRZDzAf69lkvDaLlx4oqabe-dkCLonFYMOTBTw5Cb8: Connection refused",
"status": 400
},
"url": "https://acme-v02.api.letsencrypt.org/acme/chall-v3/20373779950/E9TlgA",
"token": "crRZDzAf69lkvDaLlx4oqabe-dkCLonFYMOTBTw5Cb8",
"validationRecord": [
{
"url": "http://panel.tlwebservices.co.uk/.well-known/acme-challenge/crRZDzAf69lkvDaLlx4oqabe-dkCLonFYMOTBTw5Cb8",
"hostname": "panel.tlwebservices.co.uk",
"port": "80",
"addressesResolved": [
"212.159.153.2"
],
"addressUsed": "212.159.153.2"
}
],
"validated": "2021-08-09T15:52:21Z"
}'
[Mon 9 Aug 16:52:24 BST 2021] _json_decode
[Mon 9 Aug 16:52:24 BST 2021] _j_str='{
"type": "http-01",
"status": "invalid",
"error": {
"type": "urn:ietf:params:acme:error:connection",
"detail": "Fetching http://panel.tlwebservices.co.uk/.well-known/acme-challenge/crRZDzAf69lkvDaLlx4oqabe-dkCLonFYMOTBTw5Cb8: Connection refused",
"status": 400
},
"url": "https://acme-v02.api.letsencrypt.org/acme/chall-v3/20373779950/E9TlgA",
"token": "crRZDzAf69lkvDaLlx4oqabe-dkCLonFYMOTBTw5Cb8",
"validationRecord": [
{
"url": "http://panel.tlwebservices.co.uk/.well-known/acme-challenge/crRZDzAf69lkvDaLlx4oqabe-dkCLonFYMOTBTw5Cb8",
"hostname": "panel.tlwebservices.co.uk",
"port": "80",
"addressesResolved": [
"212.159.153.2"
],
"addressUsed": "212.159.153.2"
}
],
"validated": "2021-08-09T15:52:21Z"
}'
[Mon 9 Aug 16:52:24 BST 2021] response='{"type":"http-01","status":"invalid","error":{"type":"urn:ietf:params:acme:error:connection","detail":"Fetching http://panel.tlwebservices.co.uk/.well-known/acme-challenge/crRZDzAf69lkvDaLlx4oqabe-dkCLonFYMOTBTw5Cb8: Connection refused","status": 400},"url":"https://acme-v02.api.letsencrypt.org/acme/chall-v3/20373779950/E9TlgA","token":"crRZDzAf69lkvDaLlx4oqabe-dkCLonFYMOTBTw5Cb8","validationRecord":[{"url":"http://panel.tlwebservices.co.uk/.well-known/acme-challenge/crRZDzAf69lkvDaLlx4oqabe-dkCLonFYMOTBTw5Cb8","hostname":"panel.tlwebservices.co.uk","port":"80","addressesResolved":["212.159.153.2"],"addressUsed":"212.159.153.2"}],"validated":"2021-08-09T15:52:21Z"}'
[Mon 9 Aug 16:52:24 BST 2021] original='{"type":"http-01","status":"invalid","error":{"type":"urn:ietf:params:acme:error:connection","detail":"Fetching http://panel.tlwebservices.co.uk/.well-known/acme-challenge/crRZDzAf69lkvDaLlx4oqabe-dkCLonFYMOTBTw5Cb8: Connection refused","status": 400},"url":"https://acme-v02.api.letsencrypt.org/acme/chall-v3/20373779950/E9TlgA","token":"crRZDzAf69lkvDaLlx4oqabe-dkCLonFYMOTBTw5Cb@@@

My web server is (include version): apache

The operating system my web server runs on is (include version):debian 10

My hosting provider, if applicable, is: ispconfig at my location

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): ispconfig 3.2.5

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): acme, looks like 3.0.1 from .acme.sh

1 Like

I am not familiar with ispconfig and how it works with acme.sh. However, it looks like your weberver is not running (probably because ispconfig is trying to using nginx instead of apache) and Let's Encrypt cannot connect to satisfy the challenge. It seems like ispconfig has a set of forums and they might be able to help with the specific issue your facing with their installer/client. Once that issue is resolved you can get help here if you encounter any problems with the Let's Encrypt ACME API.

What is the specific command? It looks like they have some 'Advanced Options' where you can set the webserver https://www.howtoforge.com/ispconfig-autoinstall-debian-ubuntu/#-advanced-options

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.