Error when i try ./certbot-auto


#1

Hi everybody,

I have a new fresh VPS with ISP Config. I configure it with this tuto : https://www.howtoforge.com/tutorial/ispconfig-install-script-debian/

After installing cerbot, when i do ./certbot-auto i have this error message :

Certbot doesn’t know how to automatically configure the web server on this system. However, it can still get a certificate for you. Please run “certbot-auto certonly” to do so. You’ll need to manually configure your web server to use the resulting certificate.
Saving debug log to /var/log/letsencrypt/letsencrypt.log

So, i go to /var/log/letsencrypt/letsencrypt.log . In this log i have :

2016-11-18 08:16:26,450:DEBUG:certbot.plugins.disco:Other error:(PluginEntryPoint#apache): (‘There has been an error in parsing the$
Traceback (most recent call last):
File “/root/.local/share/letsencrypt/local/lib/python2.7/site-packages/certbot/plugins/disco.py”, line 106, in prepare
self.initialized.prepare()
File “/root/.local/share/letsencrypt/local/lib/python2.7/site-packages/certbot_apache/configurator.py”, line 190, in prepare
self.check_parsing_errors(“httpd.aug”)
File “/root/.local/share/letsencrypt/local/lib/python2.7/site-packages/certbot_apache/augeas_configurator.py”, line 74, in check
$
raise errors.PluginError(msg)
PluginError: (‘There has been an error in parsing the file (%s): %s’, u’/etc/apache2/mods-enabled/suphp.conf’, u’Syntax error’)
2016-11-18 08:16:26,451:DEBUG:certbot.plugins.selection:No candidate plugin
2016-11-18 08:16:26,451:DEBUG:certbot.plugins.selection:Selected authenticator None and installer None

Do you have an idea ? I’m beginner so, i don’t know what to do :frowning:

Thanks for help.


#2

Since both certbot and ISPconfig will edit / modify your apache files you need to take great care using the two together.

What version of ISPconfig are you using ? I believe from version 3.1 onwards ISPconfig includes letsencrypt within it’s scripts - so you could use that.

Alternatively you can use certbot in “certonly” mode, with webroot - and then set up a symlink from the ISPconfig SSL locations to the letsencrypt locations - and all should be good.

What command did you actually run ? did you tell it what domains to add to the certificate ?


#3

Thanks for your reply.

I’m using the latest version of ISP Config (3.1.1p1).

I have tried ./path/to/certbot-auto --apache certonly and i have a new error message like this

The apache plugin is not working; there may be problems with your existing configuration.
The error was: PluginError((‘There has been an error in parsing the file (%s): %s’, u’/etc/apache2/mods-enabled/suphp.conf’, u’Syntax error’),)

I think it is the apache config my problem, but i don’t know how to repair it.


#4

You can’t - because ISPconfig writes it in that format.

You will need to use the certonly webroot method if you want to use certbot - see the documentation at https://certbot.eff.org/docs/using.html

Alternatively, remove certbot - and use the plugin in ISPconfig - see https://www.howtoforge.com/tutorial/perfect-server-debian-8-4-jessie-apache-bind-dovecot-ispconfig-3-1/2/#-install-lets-encrypt


#5

Same problem with https://www.howtoforge.com/tutorial/perfect-server-debian-8-4-jessie-apache-bind-dovecot-ispconfig-3-1/2/#-install-lets-encrypt.

Do you know how to use Let’s encrypt include with ispconfig 3.1 ?
If it is include i think we can use it easily no ?


#6

personally, no ( I use the getssl script which I wrote - not certbot )


#7

Ok, thanks serverco.

If someone have an idea how to use letsencrypt include in ispconfig 3.1 i will be happy :slight_smile:


#8

It’s probably worth asking on the ISPconfig forums as well.


#9

I thnik i have find, and its so so so easy !
Just go on the website config in isp and activate SSL and Let’s Encrypt and activate the redirection to https and it work perfectly ! Amazing


#10

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.