Is my certificate renewed?

I got a Let's Encrypt certificate expiration notice email. When I visit and type in domain it shows a certificate renewed on 2023-11-01 however listing certificates with sudo certbot certificates is showing "No certificates found." I'm not sure if this means the certificate has been renewed or not.

My domain is:

I ran this command: sudo certbot certificates

It produced this output: Saving debug log to /var/log/letsencrypt/letsencrypt.log

No certificates found.

My web server is (include version): linux

The operating system my web server runs on is (include version): Ubuntu

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 2.7.4

Hi @tcim, and welcome to the LE community forum :slight_smile:

There are free online tools to check certificate issuances.

You could also [freely] check the certificate currently being server with:

That said... How did you end up here [looking for that information]?
[I'm having a hard time imagining the search engine string that led you here]


Are you on the right system?
Are you sure it is using certbot to manage the certificates?


The website is setup with nginx, which is using letsencrypt (how I ended up here) and is running on a docker-compose image. In the docker-compose.yml file certbot has it's own image. So I believe it is using certbot.

Then you need to run "certbot certificates" within that docker container.


Inside the certbot container? It's weird cause there isn't a certbot container running even though it is in the docker-compose file. When I run docker-compose up it says the following:

Recreating server-taguette-1  ... done
Recreating server-wordpress-1 ... done
Recreating server-nginx-1     ... done
Recreating server-certbot-1   ... done
Attaching to server_certbot_1
certbot_1       | Saving debug log to /var/log/letsencrypt/letsencrypt.log
certbot_1       | Certificate not yet due for renewal
certbot_1       | 
certbot_1       | - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
certbot_1       | Certificate not yet due for renewal; no action taken.
certbot_1       | - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
server_certbot_1 exited with code 0

It seems the certbot docker container is only up while it is needed.
[which is perfectly fine]

I would expect it to provide more output.
But, none-the-less, it does show:

Which implies there is/are cert(s) and none of them need to be renewed.

If you want to see the complete status of the cert(s), you will have to learn how to start/stop the container and run specific commands in it [while it is running].
If you don't know how to do any of that, then I suggest going through the documentation for that software.


Looking at | it looks like your cert was renewed a few days ago. And your nginx is also using this most recent certificate.

So from the looks of it, everything went just fine.


It does appear that way. Thanks for taking a look!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.