Is it possible to use certbot on fedora 23?

My domain is: harshrathod.dev

I ran this command: sudo certbot --apache

It produced this output: An unexpected error occurred:
The client lacks sufficient authorization :: Account creation on ACMEv1 is disabled. Please upgrade your ACME client to a version that supports ACMEv2 / RFC 8555. See End of Life Plan for ACMEv1 for details.
Please see the logfiles in /var/log/letsencrypt for more details.

My web server is (include version): Apache/2.4.23 (Fedora)

The operating system my web server runs on is (include version): Fedora 23

My hosting provider, if applicable, is: Hostinger

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 0.9.3

Hi @harshrathod50

your certbot is too old.

  • Try to install certbot-auto
  • switch to another client, may be acme.sh

Or check

2 Likes
[root@vps47654603 ~]# dnf install certbot-auto
Last metadata expiration check: 0:31:52 ago on Mon Mar 23 14:28:28 2020.
No package certbot-auto available.
Error: Unable to find a match.

Now acme.sh is the only option I guess.

you won’t find certbot-auto in there. https://certbot.eff.org/lets-encrypt/pip-other

1 Like

And that solved my problem. Thank you so much. :relieved:

1 Like