Invalid response

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: campingtreumal.com

I ran this command: sudo certbot --apache -d campingtreumal.com -d www.campingtreumal.com

It produced this output:
Domain: www.campingtreumal.com
Type: unauthorized
Detail: Invalid response from
http://www.campingtreumal.com/.well-known/acme-challenge/opiFjaCbKYKRdif2cY7ScMaNpwmaedXZUK_j1zxEEak
[51.91.125.254]: "\n\n \n

\n <meta nam"

Domain: campingtreumal.com
Type: unauthorized
Detail: Invalid response from
http://campingtreumal.com/.well-known/acme-challenge/8m9UbUgvG96C5F1ivQfehjX-DqOLGH7gQ35Hlbl31LY
[51.91.125.254]: "\n\n \n

\n <meta nam"

To fix these errors, please make sure that your domain name was
entered correctly and the DNS A/AAAA record(s) for that domain
contain(s) the right IP address.

My web server is (include version):
CPU:2 vCores
RAM:4 GiB
Disk: 50 GiB

The operating system my web server runs on is (include version):
Ubuntu 16.04 Server

My hosting provider, if applicable, is:
OVH

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):


I’ve tested in https://letsdebug.net/ and the response was: All OK! No issues were found with www.campingtreumal.com. If you are having problems with creating an SSL certificate, please visit the …

The Virtual hostl is named: 000-default-ssl.conf

<VirtualHost *:80>
ServerAdmin webmaster@localhost
ServerName campingtreumal.com
ServerAlias www.campingtreumal.com
ServerAlias *.campingtreumal.com
DocumentRoot /var/www/WebTreumal/web

    <Directory /var/www/WebTreumal/web>
            AllowOverride None
            Order Allow,Deny
            Allow from All
            <IfModule mod_rewrite.c>
                Options -MultiViews
                RewriteEngine On
                RewriteCond %{REQUEST_FILENAME} !-f
                RewriteRule ^(.*)$ app.php [QSA,L]
            </IfModule>
    </Directory>
    ErrorLog ${APACHE_LOG_DIR}/error.log
    LogLevel warn
    CustomLog ${APACHE_LOG_DIR}/access.log combined

Thank you very much,

1 Like

You might want to try using the --webroot -w option with:

with domains:

[DO NOT INCLUDE “*.campingtreumal.com” - that would require DNS authentication]

Or see if you can straighten out the apache config.
Start by reviewing the output of:
apachectl -S

1 Like

Hi @acabeza

checking your domain the basics are ok - https://check-your-website.server-daten.de/?q=campingtreumal.com

But the check of /.well-known/acme-challenge/random-filename - there is a long, very long output.

That’s a Symfony:

No route found for "GET /.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de" 

Looks like there are additional steps required so your server can handle static files in

/.well-known/acme-challenge

correct. But I don’t know how Symfony works.

1 Like

Hi @rg305,

Thank you for your response.

I’ve remove “*.campingtreumal” as a server alias.

And the output of apachectl -S is:
VirtualHost configuration:
*:80 is a NameVirtualHost
default server campingtreumal.com (/etc/apache2/sites-enabled/000-default-ssl.conf:9)
port 80 namevhost campingtreumal.com (/etc/apache2/sites-enabled/000-default-ssl.conf:9)
alias www.campingtreumal.com
port 80 namevhost www.campingtreumal.com (/etc/apache2/sites-enabled/default-ssl.conf:9)
alias campingtreumal.com
wild alias *.campingtreumal.com
wild alias *.campingtreumal.com
wild alias *.campingtreumal.es
ServerRoot: “/etc/apache2”
Main DocumentRoot: “/var/www/html”
Main ErrorLog: “/var/log/apache2/error.log”
Mutex mpm-accept: using_defaults
Mutex watchdog-callback: using_defaults
Mutex rewrite-map: using_defaults
Mutex default: dir="/var/lock/apache2" mechanism=fcntl
PidFile: “/var/run/apache2/apache2.pid”
Define: DUMP_VHOSTS
Define: DUMP_RUN_CFG
User: name=“www-data” id=33
Group: name=“www-data” id=33

I don’t understand what and how I must use the --webroot -w?

Sorry I’m not an expert slight_smile:

thanks for your help and your patience!

1 Like

Hi JuergenAuer,

Thanks for your response.

It’s possible that these errors are from DNS? I’ve seen symfony code but I see all correct…

Thanks for your help,

1 Like

The syntax, and your specific path, is:
--webroot -w /var/www/WebTreumal/web
[that would replace the use of --apache]
[you may need to also include certonly if that isn’t clear enough to certbot]

So… it would look like:
sudo certbot --webroot -w /var/www/WebTreumal/web -d campingtreumal.com -d www.campingtreumal.com
or
sudo certbot certonly --webroot -w /var/www/WebTreumal/web -d campingtreumal.com -d www.campingtreumal.com

1 Like

That’s not a DNS problem. That’s your server answer.

1 Like

It’s works! thank you rg305!

I’ve must to reinstall certificate after with: sudo certbot --apache -d campingtreumal.com -d www.campingtreumal.com

Because only with webroot don’t redirect all the traffic to https and it didn’t works.

But now works perfectly.

Thank you very much rg305 and JuergenAuer for your help and patience. :slight_smile:

2 Likes