Invalid response from

Hi there,
I tried the let’s encrypt challenge with ACMESharp to renew the ssl certificate.
After running the command Submit-ACMEChallenge -Ref “factutic-2019-10-104” -Challenge http-01

And I checked the status here:
https://acme-v01.api.letsencrypt.org/acme/chall-v3/718458564/h4yM-g

I got that error:

"Invalid response from http://app.factutic.com/.well-known/acme-challenge/S36dedVVxeKg9DVfLFkJShu88LbZD53b2irExQ3YIbc [89.36.213.52]: “\xff\xfeS\x003\x006\x00d\x00e\x00d\x00V\x00V\x00x\x00e\x00K\x00g\x009\x00D\x00V\x00f\x00L\x00F\x00k\x00J\x00S\x00h\x00u\x008\x008\x00L\x00b\x00Z\x00D\x005\x003\x00b\x002\x00i\x00r\x00E\x00x\x00Q\x003\x00Y\x00I\x00b\x00c\x00.\x00z\x00V\x00o\x00O\x002\x00u\x00O\x00t\x00f\x000\x00q\x007\x007\x00i\x00p\x00I\x00N\x000\x00l\x00"”

My domain is:
app.factutic.com

I ran this command:
After running the command Submit-ACMEChallenge -Ref “factutic-2019-10-104” -Challenge http-01

It produced this output:

My web server is (include version):
IIS 8.5

The operating system my web server runs on is (include version):
Windows Server 2012 R2

My hosting provider, if applicable, is:
arubacloud

I will be glad to get some help.
Thank you

1 Like

Hi @oscarsoler

that’s a curious error.

Checking your validation file

http://app.factutic.com/.well-known/acme-challenge/S36dedVVxeKg9DVfLFkJShu88LbZD53b2irExQ3YIbc

the content looks ok.

But checking the header - oh, why sees the online check https://check-your-website.server-daten.de/?q=app.factutic.com a timeout?

Checked with an offline tool

D:>download http://app.factutic.com/.well-known/acme-challenge/S36dedVVxeKg9DVfLFkJShu88LbZD53b2irExQ3YIbc -h
SystemDefault
Accept-Ranges: bytes
Content-Length: 176
Content-Type: text/plain
Date: Thu, 10 Oct 2019 18:32:14 GMT
ETag: “ecd4c7c7957fd51:0”
Last-Modified: Thu, 10 Oct 2019 18:08:55 GMT
Server: Microsoft-IIS/8.5
X-Powered-By: ASP.NET

Status: 200 OK

there is a length of 176 bytes, but 87 / 88 bytes are expected. Your server sends the text file as UTF-16, not as plain ASCII / UTF-8.

The first two bytes - \xff\xfe - that’s the UTF-16 BOM (Byte Order Mark).

Did you open the validation file with an editor?

5 Likes

Indeed, I edited with an editor and it was not in UTF-8.
Thank you very much.

4 Likes

Nice catch!    

2 Likes