Invalid Cert on new server install

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: lexadyfitness.com

I ran this command:

apachectl -t -D DUMP_VHOSTS

It produced this output:

Syntax error on line 8 of /etc/httpd/conf/httpd-le-ssl.conf:
SSLCertificateFile: file ‘/etc/letsencrypt/live/www.lexadyfitness.com/cert.pem’ does not exist or is empty

Also when I nano into this directory it shows I have a certificate:
b
My web server is (include version): Apache

The operating system my web server runs on is (include version): CentOS 6

My hosting provider, if applicable, is: OVH

I can login to a root shell on my machine (yes or no, or I don’t know): YES

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 0.40.1

Also, when forcing HTTPS my server switches over to the default apache install page. I have installed wordpress on my server and it only works when HTTPS is not active.

Any help would be so very much appreciated, have been researching and scratching my head over this for hours.

Installation seemed to go smooth, I originally had this server on Cloudflare and I removed it from cloudflare and switched over to a namecheap dns to see if Cloudflare was the issue, it was not.

Please show the output of:
certbot certificates
and also of:
ls -l /etc/letsencrypt/live/www.lexadyfitness.com/

1 Like

certbot certificates

-bash: certbot: command not found

sudo ls -l /etc/letsencrypt/live/www.lexadyfitness.com/

total 4
lrwxrwxrwx 1 root root 45 Nov 27 22:57 cert.pem -> …/…/archive/www.lexadyfitness.com/cert1.pem
lrwxrwxrwx 1 root root 46 Nov 27 22:57 chain.pem -> …/…/archive/www.lexadyfitness.com/chain1.pem
lrwxrwxrwx 1 root root 50 Nov 27 22:57 fullchain.pem -> …/…/archive/www.lexadyfitness.com/fullchain1.pem
lrwxrwxrwx 1 root root 48 Nov 27 22:57 privkey.pem -> …/…/archive/www.lexadyfitness.com/privkey1.pem
-rw-r–r-- 1 root root 692 Nov 27 22:57 README

1 Like

The files look good.

But however you got that, get the certificates.

2 Likes

c

1 Like

Then please show:
certbot-auto certificates

2 Likes

1 Like

There seems to be an error in this file:

Please show the whole file.

1 Like

<VirtualHost *:443>

ServerAdmin admin@lexadyfitness.com

DocumentRoot /var/www/lexadyfitness.com/public_html

ServerName www.lexadyfitness.com

ErrorLog /var/www/lexadyfitness.com/error.log

CustomLog /var/www/lexadyfitness.com/requests.log common

SSLCertificateFile /etc/letsencrypt/live/www.lexadyfitness.com/cert.pem

SSLCertificateKeyFile /etc/letsencrypt/live/www.lexadyfitness.com/privkey.pem

Include /etc/letsencrypt/options-ssl-apache.conf

SSLCertificateChainFile /etc/letsencrypt/live/www.lexadyfitness.com/chain.pem

there are if modules but they wont show up in the text there.

image

1 Like

im just going to try to do a new server install, thanks for the help anyways

edit: I got it working after a fresh server install on centos 7. Centos 6 gave me a ton of bugs but the new installation worked no problem

2 Likes