"Internal Server Error" when requesting a certificate for my new non-duckdns domain. Old duckdns domain DOES work

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: (plex).istria.cc

I ran this command:
Using "NGINX Proxy Manager" as a reverse proxy.

It produced this output:
"Internal Server Error"

My web server is (include version):
Plex (as an example)

The operating system my web server runs on is (include version):
Ubuntu 22.04

My hosting provider, if applicable, is:
Self-hosted in a Proxmox LXC container.

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):
Nginx Proxy Manager

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):
Sorry, don't know since I'm not running "naked" certbot, but the Nginx Proxy Manager GUI.

Hi all,

I've run into a (probably noob) problem:

I'm running a couple of services on my homeserver. It's basically a PC running Proxmox connected to the ISP modem/router.

On my ISP modem, I have forwarded ports 80 and 443 to the container on Proxmox that is running Nginx Proxy Manager as a reverse proxy ( And I have a duckdns domain that points to my public IP address.
From Nginx Proxy Manager, I forward different subdomains to different ips. For example "plex.istria.duckdns.org" points to ip, which is my plex server. And "openproject.istria.duckdns.org" points to ip, which is my openproject instance.

When I configure these so called "proxy hosts" in Nginx Proxy Manager, I have the option to request a LetsEncrypt certificate, which works as expected. It gets a certificate for the "proxy host". And then I can go to https://plex.istria.duckdns.org from anywhere and reach my plex server via SSL connection.

So far so good. Now the problem:

Yesterday, I registered a domain at namesilo: "istria.cc". I deleted the existing DNS A records and added a new A record that points to my public IP address. Which seemed to work, because when I go to www.istria.cc, I get the Nginx Proxy Manager "congratulations" page. Also when I ping istria.cc, it pings my public ip.

Then I added a new "proxy host" in Nginx Proxy Manager in the same way I did before for the duckdns domain.
The first thing that went wrong is that requesting a ssl certificate failed. It said "internal server error". And also without the certificate, I can't seem to reach my plex server via "plex.istria.cc". I also can't ping it.
I tried (for testing) to make a new proxy host "testtwee.istria.duckdns.org", and this works fine. But testtwee.istria.cc does not work.

Any idea if I'm doing something wrong? This is my first time using a non-duckdns domain. So maybe I'm missing a step?

Thanks in advance for the help!

Update: I might have found the issue. I only have 1 DNS A record. That of istria.cc.
I now added also a second A record www.istria.cc to also point to my ip. I think this might have been the mistake I made.
We'll see in an hour when the DNS updates.

Update 2:

Ok, problem solved.
It was indeed a noobish mistake.

Apparantly duckdns forwards all hostnames automatically to the root domain. That's why it worked there.

Namesilo does not. You have to create an A record for each hostname/subdomain and point it to the ip or root domain.

Or how I did it:

Type ¦ Hostname ¦ Address

CNAME ¦ * ¦ istria.duckdns.org

So this way it simply points all hostnames to my duckdns domain. Which points to my public ip address.

And now the certificate request also works as expected. =)


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.