Internal Error When Generating SSL Certificate

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:
Tried to generate an SSL certificate using letsencrypt on NGINX

It produced this output:
[9/4/2023] [8:17:43 PM] [Nginx ] › :information_source: info Reloading Nginx
[9/4/2023] [8:17:52 PM] [Nginx ] › ⬤ debug Deleting file: /data/nginx/proxy_host/1.conf
[9/4/2023] [8:17:52 PM] [Nginx ] › ⬤ debug Deleting file: /data/nginx/proxy_host/1.conf.err
[9/4/2023] [8:17:52 PM] [Nginx ] › ⬤ debug Could not delete file: {
"errno": -2,
"syscall": "unlink",
"code": "ENOENT",
"path": "/data/nginx/proxy_host/1.conf.err"
[9/4/2023] [8:17:52 PM] [Nginx ] › :information_source: info Reloading Nginx
[9/4/2023] [8:17:57 PM] [SSL ] › :information_source: info Requesting Let'sEncrypt certificates for Cert #1:
[9/4/2023] [8:17:57 PM] [SSL ] › :information_source: info Command: certbot certonly --config "/etc/letsencrypt.ini" --work-dir "/tmp/letsencrypt-lib" --logs-dir "/tmp/letsencrypt-log" --cert-name "npm-1" --agree-tos --authenticator webroot --email "imagine you see my email here" --preferred-challenges "dns,http" --domains ""
[9/4/2023] [8:18:11 PM] [Nginx ] › ⬤ debug Deleting file: /data/nginx/temp/letsencrypt_1.conf
[9/4/2023] [8:18:11 PM] [Nginx ] › :information_source: info Reloading Nginx
[9/4/2023] [8:18:11 PM] [Express ] › :warning: warning Command failed: certbot certonly --config "/etc/letsencrypt.ini" --work-dir "/tmp/letsencrypt-lib" --logs-dir "/tmp/letsencrypt-log" --cert-name "npm-1" --agree-tos --authenticator webroot --email "imagine you see my email here" --preferred-challenges "dns,http" --domains ""
Saving debug log to /tmp/letsencrypt-log/letsencrypt.log
Some challenges have failed.
Ask for help or search for solutions at See the logfile /tmp/letsencrypt-log/letsencrypt.log or re-run Certbot with -v for more details.

My web server is (include version):

The operating system my web server runs on is (include version):
Unraid 6.12.1

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):
I don't know

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):
Google Domains

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):
Unsure as this runs in a docker

I should also note, that there is no log output to be found

Hi @AcEGDSZ, and welcome to the LE community forum :slight_smile:

I see:

but I don't see the web root path being used.

What shows?:
certbot certificates


Hello, and thank you! I'm sorry, I'm relatively new to this, so please bear with me lol. Where would enter that? I have NGINX running as a docker within unraid, so I am unsure where to enter that.

Wait, nevermind. I entered it in the console, and it said no certificates found

So, this is the first cert then.
Why are you using Nginx Proxy Manager?


I have previously generated certs before with no problem, only today, these problems started. I was no longer able to access my website, so upon checking the certs, they seemed fine, so I attempted to re-create them, and then this issue started. I've cleanly reinstalled the docker to no avail, and yes I am using Nginx Proxy Manager.

Looks like your domain cannot be reached using HTTP. At least not by Let's Debug or the Let's Encrypt servers.

This is most likely a firewall or possibly a port mapping problem at your site


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.