Installing step-ca

The operating system my web server runs on is (include version): Debian 10

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): newest

I tried to install step-ca but I'm stuck. By default it installs in root directory and thus I can't start step-ca service due to permission denied error. I tried dpkg -i with /home/step but doesn's work.

1 Like

Hi @Serpher,

Is your issue with step-ca related to issuance of Let's Encrypt certificates? If not, i would suggest you to visit GitHub - smallstep/certificates: 🛡️ A private certificate authority (X.509 & SSH) & ACME server for secure automated certificate management, so you can use TLS everywhere & SSO for SSH. and open an issue there.

If you want to request certificates, you should use the step CLI instead of step ca.

P.S. By default, step ca suggest you to install on root and run it as a Daemon with systemd service user. Certificate authority server production considerations — Smallstep

3 Likes

This seems like the way you want to go based on what you had posted on Reddit.

3 Likes