Installing SSL: Invalid response from

I installed Wiki.js with the "one click" install from digitalocean and now want to assign SSL Certificate to that subdomain. However, I ran into the problem below.

My domain is:

I ran this command: certbot certonly --webroot

It produced this output:

Certbot failed to authenticate some domains (authenticator: webroot). The Certificate Authority reported these problems:
  Type:   unauthorized
  Detail: Invalid response from [***]: 418

Hint: The Certificate Authority failed to download the temporary challenge files created by Certbot. Ensure that the listed domains serve their content from the provided --webroot-path/-w and that files created there can be downloaded from the internet.

My web server is (include version): Actually no idea, it runs on docker. (Never used this, as why I am inexperienced)

The operating system my web server runs on is (include version): Ubuntu 20

My hosting provider, if applicable, is: digitalocean

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 1.25.0

Have you read the relevant documentation for wiki.js + Let's Encrypt?

It would appear that they have a specific process to obtain and install an SSL certificate, rather than using Certbot.


Lol you are a legend, it actually worked.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.