Installing fails on Debian Stretch


#1

My domain is:

I ran this command:
apt-get install python-certbot-apache -t stretch-backports

It produced this output:
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
python-certbot-apache : Depends: certbot (>= 0.19.0~) but it is not going to be installed
Depends: python-certbot but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

My web server is (include version):

Apache2 (2.4.25)

The operating system my web server runs on is (include version):

Debian Stretch

Fully updated.

I can login to a root shell on my machine (yes or no, or I don’t know):

Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

No

Not installing on Debian Stretch. Backports is enabled. I also tried downloading deb files myself. But the same errors occur.

Is the repository bugged or am I having issues at my side?

Cheers,
Maurice


#2

It’s the repository. :sweat:

You can work around the issue, or just wait for Debian to fix it.


#3

Ugh ok :frowning: Sorry for the duplicate. Thanks!