Installing Certbot on Debian 7

Hi to you all!
This is my linux dist:
Linux vps-1019199-x 3.2.0-4-amd64 #1 SMP Debian 3.2.65-1+deb7u1 x86_64

I cannot install certbot (i am following apache-debian9 instructions).

When i run:
apt-get install certbot python-certbot-apache

I get this result:

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package certbot
E: Unable to locate package python-certbot-apache

Searching i found something like this:
apt-get install certbot python-certbot-apache -t wheezy-backports main

but i still get an error:

Reading package lists... Done
E: The value 'wheezy-backports' is invalid for APT::Default-Release as such a release is not available in the sources

Dispite mi source.list file content

deb http://deb.debian.org/debian/ wheezy-backports main
deb-src http://deb.debian.org/debian/ wheezy-backports main

I will appreciate any help (i am newbie with linux!).
Thanks you all!

1 Like

I orriginally posted a suggestion to use snap. However after reading my linked document I discovered that Snap is currently unavailable on versions of Debian prior to 9.
Sorry.

2 Likes

I saw that... i tried that before... not working either. I do not realize version issue at that moment.

1 Like

Welcome to the Let's Encrypt Community :slightly_smiling_face:

I'm trying to track down a solution for you.

@Speaker
I'm kinda thinking you already know:
Debian 7.0 Codename Wheezy was released on May 4, 2013 with End of Life April 26, 2016. (LTS May 2018)
I doubt you are getting any significant security updates, etc.
Have you considered updating the OS? Would make a huge difference for you.

2 Likes

Perhaps this may help?

Let's Encrypt TLS certificate setup for Apache on Debian 7

1 Like

No security updates since 2018 any more..

I wouldn't dare to connect that server to the internet if I was @Speaker

3 Likes

I was going to ask if there was a reason :confounded: Ultimately there is no legit reason to run this version and expect anything but problems. (Possibly in a CEH lab on a VM)

2 Likes

Regardless, I think the link I supplied will probably allow it. I provided the instructions for Pandora's box. If the user chooses, well...

1 Like

Not very much unlike Windows XP: no legit reason to have it connected to the internet.

3 Likes

As you said, there is no reason to keep that version... but...
It's a cloud server, running legacy apps that's has to be working 7x24, svn repositories, postgresql databases. So upgrading debian version may be mandaroty, but it's risky and time demanding. As i said i am newbie to Linux, and can't afford the time and money required to upgrade.
As i probably use the server to give ftp access to others legacy desktop apps, i will like to add some security, with the resources i can set at the moment.
Following the link @griffin... but, i get this:

The following packages have unmet dependencies:
 git : Depends: liberror-perl but it is not installable
       Recommends: patch but it is not installable
       Recommends: less but it is not installable
1 Like

Try using something self-contained like lego which does not depend on anything from the operating system.

Debian 7 is more than 2 years EOL, you're not going to have a lot of options.

2 Likes

That is an awesome suggestion.

When I was on the Certbot team, there were fairly regular efforts to remove our documentation on how to install Certbot on operating systems that were no longer supported by their developers. The reason for this was (apart from the security risks of running an OS that doesn't get security updates) that dependencies could sometimes start to conflict, like Certbot wanted an OS dependency of a certain version that was no longer available on unsupported OS versions.

So when you don't find official Certbot installation instructions in this situation, it's probably intentional!

It's true that other ACME clients with fewer dependencies, including lego and acme.sh, will commonly work on some older and out-of-support OSes.

2 Likes