Installed certbot earlier, work properly one site, but not the other

Hello, thanks for helping me.

I have 3 domains for 2 sites : and for the first site for the second site.

I ran the commands i found on the official documentation for debian 10 on apache :

1 : apt install snapd
2 : snap install core; snap refresh core
3 : snap install --classic certbot
4 : ln -s /snap/bin/certbot /usr/bin/certbot
5 ; i ran "certbot --apache" and indicated my 3 domains
everything was OK

6 : i restarted my apache "systemctl restart apache2"

It worked properly on, but didn't work on

i had no special output who indicate issue

My web server is : Server version: Apache/2.4.56 (Debian)
Server built: 2023-03-08T03:05:04

on debian bullseye up to date : SMP Debian 5.10.162-1 (2023-01-21) x86_64 GNU/Linux

My hosting provider, if applicable, is:

I can login to a root shell on my machine : yup:

I'm using a control panel to manage my site (no, but i can)

im using certbot 2.5.0

i check my apache site-enable, bot ssl configuration for the virtual host are there.

Thx for reading this, and sorry for my english. hope you can help.

I also tried something elese after,

I regenerated one certificat for all my domains like this :

certbot -d -d -d

and restarted again, no succed

Hello @bastian, welcome to the Let's Encrypt community. :slightly_smiling_face:

You are correct; the certificate has the Subject Alt Names (SANs)

The issue is redirect to and is NOT in the Certificate's SANs.

$ curl -Ii
HTTP/1.1 301 Moved Permanently
Date: Thu, 06 Apr 2023 15:01:04 GMT
Server: Apache/2.4.56 (Debian)
Expires: Thu, 06 Apr 2023 16:01:04 GMT
Cache-Control: max-age=3600
X-Redirect-By: WordPress
Content-Type: text/html; charset=UTF-8
$ curl -Ii
curl: (60) SSL: no alternative certificate subject name matches target host name ''
More details here:

curl failed to verify the legitimacy of the server and therefore could not
establish a secure connection to it. To learn more about this situation and
how to fix it, please visit the web page mentioned above.
1 Like

so i should add an ServerAlias on my virtualhost for

like that :

        serverAlias                <= just added
        DocumentRoot /var/www/normandytour

        <Directory /var/www/normandytour>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride All
                Require all granted
                Order allow,deny
                allow from all

re-run cerbot --apache


and regenerate certificate ?

or maybe just add the new to the SAN ?

That would be my choice.


how would you do that ?

like certbot -d -d -d -d -d

and select Expend

finish with apache2 restart

Right ?

I count five entries - it should have six.
Three domains and three www.


ok so i did it with the six like you said :

certbot -d -d -d -d -d -d


restarted apache, but i still have the issue, there might be something i don't understand about this.

Please show the details.


it work on google chrome on multiple computer, but does not on mozilla ??

Clear the cache or reboot that PC.
I see all six:


I believe you have non-secure components in your web site.


Try using:
Why No Padlock?


You also can find details here Hardenize Report:


padlock said that ssl was operationnal, and was working.

It apparently work now.

Thank you for your help, appreciate it.



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.