Server on AWS EC2 - got an invalid cert for the internal hostname instead of my domain

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: certbot --apache

It produced this output:

[root@ip-172-31-25-32 conf.d]# certbot --apache
Saving debug log to /var/log/letsencrypt/letsencrypt.log

Which names would you like to activate HTTPS for?
We recommend selecting either all domains, or all domains in a VirtualHost/server block.


Select the appropriate numbers separated by commas and/or spaces, or leave input
blank to select all options shown (Enter 'c' to cancel): 1
Requesting a certificate for

Successfully received certificate.
Certificate is saved at: /etc/letsencrypt/live/
Key is saved at: /etc/letsencrypt/live/
This certificate expires on 2023-12-07.
These files will be updated when the certificate renews.
Certbot has set up a scheduled task to automatically renew this certificate in the background.

Deploying certificate
Successfully deployed certificate for to /etc/httpd/conf.d/
Congratulations! You have successfully enabled HTTPS on

If you like Certbot, please consider supporting our work by:

My web server is (include version):

[root@ip-172-31-25-32 conf.d]# httpd -v
Server version: Apache/2.4.57 (Fedora Linux)
Server built: Apr 11 2023 00:00:00

The operating system my web server runs on is (include version):

[root@ip-172-31-25-32 conf.d]# cat /etc/fedora-release
Fedora release 38 (Thirty Eight)

My hosting provider, if applicable, is: AWS EC2 (us-west-1)

I can login to a root shell on my machine (yes or no, or I don't know): Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

[root@ip-172-31-25-32 conf.d]# certbot --version
certbot 2.6.0


I am completely new to Let's Encrypt. This is the first time I have tried to enable https for this server, but I have manually installed SSL certs on previous incarnations of it (same OS and http server). I just didn't want to have to purchase a cert this time around.

I had to go through the steps a few times because I made mistakes. At first I typed in '' instead or ''. I am not sure how to get a cert that is valid for both.

Anyway, I finally got it installed, but Chrome and Edge both tell me that the cert is invalid with a ERR_CERT_AUTHORITY_INVALID error. The cert has '' for the subject and issuer instead of my domain name. How can I get a proper cert for my domain name instead? And for both the domain name and the 'www'?

If it is not possible to do this, then I will just go ahead and buy a cert from the cheapest CA I can find and install it by hand. How can I completely remove/revert the changes that certbot did?


Check all your Apache configuration files for pre-existing SSLCertificateFile / SSLCertificateKeyFile directives and remove them (try grep -IiR SSLCertificate /etc/httpd/ if you're not sure where to look)

add these if certbot didn't do it already:

SSLCertificateKeyFile /etc/letsencrypt/live/
SSLCertificateFile /etc/letsencrypt/live/

then restart Apache

1 Like

Thank you, that fixed it. I wonder why certbot didn't update ssl.conf with the proper fullchain.pem and privkey.pem files? Is it a known bug?

I personally only use certbot in "certonly" mode because I don't trust anybody or anything to update my Apache configuration without my supervision.

Also, looks like you generated your certificate only for your WWW subdomain and didn't include your apex domain. So HTTPS apex -> www redirects are not working properly unless the certificate warning is bypassed. You should request the certificate again but this time include the apex domain as well. Include --cert-name so it'll keep the same certificate name and you won't have to update your Apache configuration again.

1 Like

You should have both domain names in your Apache VirtualHost. One would be your ServerName and the other the ServerAlias. Doesn't much matter which is which.

If you had that at the start the command you showed in post #1 would have shown both domain names and your cert would have both names.

There is probably something not quite right with your Apache config. Show us this output and we can sort it out

sudo httpd -t -D DUMP_VHOSTS

Omit sudo if you don't need it


Thanks Mike. Here's the output:

[fedora@ip-172-31-25-32 ~]$ sudo httpd -t -D DUMP_VHOSTS
VirtualHost configuration:
*:443                  is a NameVirtualHost
         default server (/etc/httpd/conf.d/ssl.conf:56)
         port 443 namevhost (/etc/httpd/conf.d/ssl.conf:56)
         port 443 namevhost (/etc/httpd/conf.d/
*:80          (/etc/httpd/conf.d/

The problem is you have a name:port overlap:
[Apache is notorious for allowing such inconsistencies]

You need to look through the ssl.conf file for ServerName.
If one exists, change the name to someint innocuous.
If non exist, then look through the main http config block for ServerName and change it something that would never be served from a vhost.
[naming the server via a name that will be served by it in a vhost is bad practice - it eventually leads to this problem]
Then restart/reload Apache.


You need to look through the ssl.conf file for ServerName .
If one exists, change the name to someint innocuous.

None exist in ssl.conf.

If non exist, then look through the main http config block for ServerName and change it something that would never be served from a vhost.

I did this, and it broke the site. When I try to access I get ERR_TOO_MANY_REDIRECTS.

With this is httpd.conf:


when I access I get the homepage as expected and when I access or or it redirects to and everyone's happy. I understand that even with a bad config things can work as expected. 27 years in technical support roles has taught me that. But what I'm trying to grasp is, how should I "fix" this so that I don't break it? :rofl:

For the moment I'm going to leave it as it is, even if it's not really correct. But I do want to set it up properly so hat cert renewals will go smoothly as they occur moving forward.

Thanks for your help!

1 Like

Can you show us these 3 conf files? Please place 3 backticks before and after the contents so that key Apache info is not lost like

File: ssl.conf
contents of conf

contents of conf
and same for the 3rd


Here you go:

File: ssl.conf

[root@ip-172-31-25-32 conf.d]# cat ssl.conf
# When we also provide SSL we have to listen to the
# standard HTTPS port in addition.
Listen 443 https

##  SSL Global Context
##  All SSL configuration in this context applies both to
##  the main server and all SSL-enabled virtual hosts.

#   Pass Phrase Dialog:
#   Configure the pass phrase gathering process.
#   The filtering dialog program (`builtin' is a internal
#   terminal dialog) has to provide the pass phrase on stdout.
SSLPassPhraseDialog exec:/usr/libexec/httpd-ssl-pass-dialog

#   Inter-Process Session Cache:
#   Configure the SSL Session Cache: First the mechanism
#   to use and second the expiring timeout (in seconds).
SSLSessionCache         shmcb:/run/httpd/sslcache(512000)
SSLSessionCacheTimeout  300

#   Pseudo Random Number Generator (PRNG):
#   Configure one or more sources to seed the PRNG of the
#   SSL library. The seed data should be of good random quality.
#   WARNING! On some platforms /dev/random blocks if not enough entropy
#   is available. This means you then cannot use the /dev/random device
#   because it would lead to very long connection times (as long as
#   it requires to make more entropy available). But usually those
#   platforms additionally provide a /dev/urandom device which doesn't
#   block. So, if available, use this one instead. Read the mod_ssl User
#   Manual for more details.
SSLRandomSeed startup file:/dev/urandom  256
SSLRandomSeed connect builtin
#SSLRandomSeed startup file:/dev/random  512
#SSLRandomSeed connect file:/dev/random  512
#SSLRandomSeed connect file:/dev/urandom 512

# Use "SSLCryptoDevice" to enable any supported hardware
# accelerators. Use "openssl engine -v" to list supported
# engine names.  NOTE: If you enable an accelerator and the
# server does not start, consult the error logs and ensure
# your accelerator is functioning properly.
SSLCryptoDevice builtin
#SSLCryptoDevice ubsec

## SSL Virtual Host Context

<VirtualHost _default_:443>

# General setup for the virtual host, inherited from global configuration
#DocumentRoot "/var/www/html"

# Use separate log files for the SSL virtual host; note that LogLevel
# is not inherited from httpd.conf.
ErrorLog logs/ssl_error_log
TransferLog logs/ssl_access_log
LogLevel warn

#   SSL Engine Switch:
#   Enable/Disable SSL for this virtual host.
SSLEngine on

#   List the protocol versions which clients are allowed to connect with.
#   The OpenSSL system profile is configured by default.  See
#   update-crypto-policies(8) for more details.
#SSLProtocol all -SSLv3
#SSLProxyProtocol all -SSLv3

#   User agents such as web browsers are not configured for the user's
#   own preference of either security or performance, therefore this
#   must be the prerogative of the web server administrator who manages
#   cpu load versus confidentiality, so enforce the server's cipher order.
SSLHonorCipherOrder on

#   SSL Cipher Suite:
#   List the ciphers that the client is permitted to negotiate.
#   See the mod_ssl documentation for a complete list.
#   The OpenSSL system profile is configured by default.  See
#   update-crypto-policies(8) for more details.

#   Point SSLCertificateFile at a PEM encoded certificate.  If
#   the certificate is encrypted, then you will be prompted for a
#   pass phrase.  Note that restarting httpd will prompt again.  Keep
#   in mind that if you have both an RSA and a DSA certificate you
#   can configure both in parallel (to also allow the use of DSA
#   ciphers, etc.)
#   Some ECC cipher suites (
#   require an ECC certificate which can also be configured in
#   parallel.
#SSLCertificateFile /etc/pki/tls/certs/localhost.crt
SSLCertificateFile /etc/letsencrypt/live/

#   Server Private Key:
#   If the key is not combined with the certificate, use this
#   directive to point at the key file.  Keep in mind that if
#   you've both a RSA and a DSA private key you can configure
#   both in parallel (to also allow the use of DSA ciphers, etc.)
#   ECC keys, when in use, can also be configured in parallel
#SSLCertificateKeyFile /etc/pki/tls/private/localhost.key
SSLCertificateKeyFile /etc/letsencrypt/live/

#   Server Certificate Chain:
#   Point SSLCertificateChainFile at a file containing the
#   concatenation of PEM encoded CA certificates which form the
#   certificate chain for the server certificate. Alternatively
#   the referenced file can be the same as SSLCertificateFile
#   when the CA certificates are directly appended to the server
#   certificate for convenience.
#SSLCertificateChainFile /etc/pki/tls/certs/server-chain.crt

#   Certificate Authority (CA):
#   Set the CA certificate verification path where to find CA
#   certificates for client authentication or alternatively one
#   huge file containing all of them (file must be PEM encoded)
#SSLCACertificateFile /etc/pki/tls/certs/ca-bundle.crt

#   Client Authentication (Type):
#   Client certificate verification type and depth.  Types are
#   none, optional, require and optional_no_ca.  Depth is a
#   number which specifies how deeply to verify the certificate
#   issuer chain before deciding the certificate is not valid.
#SSLVerifyClient require
#SSLVerifyDepth  10

#   Access Control:
#   With SSLRequire you can do per-directory access control based
#   on arbitrary complex boolean expressions containing server
#   variable checks and other lookup directives.  The syntax is a
#   mixture between C and Perl.  See the mod_ssl documentation
#   for more details.
#<Location />
#SSLRequire (    %{SSL_CIPHER} !~ m/^(EXP|NULL)/ \
#            and %{SSL_CLIENT_S_DN_O} eq "Snake Oil, Ltd." \
#            and %{SSL_CLIENT_S_DN_OU} in {"Staff", "CA", "Dev"} \
#            and %{TIME_WDAY} >= 1 and %{TIME_WDAY} <= 5 \
#            and %{TIME_HOUR} >= 8 and %{TIME_HOUR} <= 20       ) \
#           or %{REMOTE_ADDR} =~ m/^192\.76\.162\.[0-9]+$/

#   SSL Engine Options:
#   Set various options for the SSL engine.
#   o FakeBasicAuth:
#     Translate the client X.509 into a Basic Authorisation.  This means that
#     the standard Auth/DBMAuth methods can be used for access control.  The
#     user name is the `one line' version of the client's X.509 certificate.
#     Note that no password is obtained from the user. Every entry in the user
#     file needs this password: `xxj31ZMTZzkVA'.
#   o ExportCertData:
#     This exports two additional environment variables: SSL_CLIENT_CERT and
#     SSL_SERVER_CERT. These contain the PEM-encoded certificates of the
#     server (always existing) and the client (only existing when client
#     authentication is used). This can be used to import the certificates
#     into CGI scripts.
#   o StdEnvVars:
#     This exports the standard SSL/TLS related `SSL_*' environment variables.
#     Per default this exportation is switched off for performance reasons,
#     because the extraction step is an expensive operation and is usually
#     useless for serving static content. So one usually enables the
#     exportation for CGI and SSI requests only.
#   o StrictRequire:
#     This denies access when "SSLRequireSSL" or "SSLRequire" applied even
#     under a "Satisfy any" situation, i.e. when it applies access is denied
#     and no other module can change it.
#   o OptRenegotiate:
#     This enables optimized SSL connection renegotiation handling when SSL
#     directives are used in per-directory context.
#SSLOptions +FakeBasicAuth +ExportCertData +StrictRequire
<FilesMatch "\.(cgi|shtml|phtml|php)$">
    SSLOptions +StdEnvVars
<Directory "/var/www/cgi-bin">
    SSLOptions +StdEnvVars

#   SSL Protocol Adjustments:
#   The safe and default but still SSL/TLS standard compliant shutdown
#   approach is that mod_ssl sends the close notify alert but doesn't wait for
#   the close notify alert from client. When you need a different shutdown
#   approach you can use one of the following variables:
#   o ssl-unclean-shutdown:
#     This forces an unclean shutdown when the connection is closed, i.e. no
#     SSL close notify alert is sent or allowed to be received.  This violates
#     the SSL/TLS standard but is needed for some brain-dead browsers. Use
#     this when you receive I/O errors because of the standard approach where
#     mod_ssl sends the close notify alert.
#   o ssl-accurate-shutdown:
#     This forces an accurate shutdown when the connection is closed, i.e. a
#     SSL close notify alert is sent and mod_ssl waits for the close notify
#     alert of the client. This is 100% SSL/TLS standard compliant, but in
#     practice often causes hanging connections with brain-dead browsers. Use
#     this only for browsers where you know that their SSL implementation
#     works correctly.
#   Notice: Most problems of broken clients are also related to the HTTP
#   keep-alive facility, so you usually additionally want to disable
#   keep-alive for those clients, too. Use variable "nokeepalive" for this.
#   Similarly, one has to force some clients to use HTTP/1.0 to workaround
#   their broken HTTP/1.1 implementation. Use variables "downgrade-1.0" and
#   "force-response-1.0" for this.
BrowserMatch "MSIE [2-5]" \
         nokeepalive ssl-unclean-shutdown \
         downgrade-1.0 force-response-1.0

#   Per-Server Logging:
#   The home of a custom SSL log file. Use this when you want a
#   compact non-error SSL logfile on a virtual host basis.
CustomLog logs/ssl_request_log \
          "%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"



[root@ip-172-31-25-32 conf.d]# cat
<IfModule mod_ssl.c>
<VirtualHost *:443>
        Redirect /

SSLCertificateFile /etc/letsencrypt/live/
SSLCertificateKeyFile /etc/letsencrypt/live/
Include /etc/letsencrypt/options-ssl-apache.conf


[root@ip-172-31-25-32 conf.d]# cat
<VirtualHost *:80>
        Redirect /
RewriteEngine on
RewriteCond %{SERVER_NAME}
RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]

Thanks again for your kind help!

Oh, gee, you have quite a mess. I only have time for some of them right now but perhaps someone else will pick up or I will look at later. These are fixing your default server for HTTPS and getting your cert to have both domain names (root and www).

Mind you, below is just standard Apache stuff. Not unique to Let's Encrypt

This is missing a ServerAlias and has competing redirect methods. Change this

To this:

<VirtualHost *:80>
RewriteEngine on
RewriteRule ^/(.*){REQUEST_URI} [R=301,L]

And in below file remove the line for redirect /
You are redirecting to itself which is causing the loop
I don't see any need for a redirect in this file if you setup the rewrite as I show above


Thanks, Mike. I've made those changes and restarted Apache, and it's working properly.

Let me know if there are any other tweaks needed. And should I run certbot again to get a new, proper certificate? I don't want to run it again until necessary since I've read of people hitting the limit.

Where is the DocumentRoot?
What content does it serve?

Please show this again:
[ I suspect you have not yet corrected that name:port overlap ]
sudo httpd -t -D DUMP_VHOSTS


They have not. The default VirtualHost still needs work. As does the cert. And anything else you might see like the DocumentRoot :slight_smile:

I don't have much time this aft else I'd have continued. Cheers


It's defined in httpd.conf:

[root@ip-172-31-25-32 conf]# grep DocumentRoot httpd.conf
# DocumentRoot: The directory out of which you will serve your
DocumentRoot "/var/www/html"
    # access content that does not live under the DocumentRoot.

Sorry, I don't know how to fix it. I don't even know what a name:port overlap is (a quick Google didn't turn up anything useful), or how I ended up with one.

[root@ip-172-31-25-32 conf]# httpd -t -D DUMP_VHOSTS
VirtualHost configuration:
*:443                  is a NameVirtualHost
         default server (/etc/httpd/conf.d/ssl.conf:56)
         port 443 namevhost (/etc/httpd/conf.d/ssl.conf:56)
         port 443 namevhost (/etc/httpd/conf.d/
*:80          (/etc/httpd/conf.d/


I already gave instructions on how to fix that.

If those instructions are not working OR you are unable to follow them OR you just didn't understand them, try:
Adding a ServerName to the ssl.conf file [ensuring it is not a name that is used, nor one that would ever be used, within any vhost].


Whoops, sorry about that. Apologies for annoying you.

In ssl.conf, I found this:


I just went ahead and uncommented that line and restarted Apache. Now I have this:

[root@ip-172-31-25-32 conf.d]# httpd -t -D DUMP_VHOSTS
VirtualHost configuration:
*:443                  is a NameVirtualHost
         default server (/etc/httpd/conf.d/ssl.conf:56)
         port 443 namevhost (/etc/httpd/conf.d/ssl.conf:56)
         port 443 namevhost (/etc/httpd/conf.d/
*:80          (/etc/httpd/conf.d/

So I guess it's "fixed". But it still looks broken to me: Why do I even have two virtual hosts on 443? I'm pretty sure I didn't do that since I didn't even have any ssl*.conf files before I ran certbot for the first time.

(I'm not trying to say that this is all certbot's fault; I just don't understand how I got here.)


1 Like

That is how it is designed to work.
Each [set of] name(s) is handled by its' own vhost config file.
For a bit more on that, see: Server Name Indication - Wikipedia

If anything is broken, then it would need to be fixed within the vhost config file:

Please explain what is broken and show that file.

And I was not annoyed - I was just being crystal clear - LOL


OK, thanks for explaining that. I'd never seen ssl set up this way before. When I configured it manually in the past, I had no virtual hosts at all.

I think it's correct now, but please let me know if not:

[root@ip-172-31-25-32 conf.d]# cat
<VirtualHost *:80>
RewriteEngine on
RewriteRule ^/(.*){REQUEST_URI} [R=301,L]
[root@ip-172-31-25-32 conf.d]# cat
<IfModule mod_ssl.c>
<VirtualHost *:443>

SSLCertificateFile /etc/letsencrypt/live/
SSLCertificateKeyFile /etc/letsencrypt/live/
Include /etc/letsencrypt/options-ssl-apache.conf

Am I ready to go ahead and run certbot again to get a proper cert for both and

@pbrown280 You need to add the ServerAlias to your le-ssl.conf too

Restart apache and then try this

certbot --apache --cert-name -d -d

It should ask if you want to expand the cert and say yes