Install ssl to only office server

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:
I ran this command:
sudo certbot certonly --webroot
It produced this output:

Certbot failed to authenticate some domains (authenticator: webroot). The Certificate Authority reported these problems:
  Type:   unauthorized
  Detail: Invalid response from 404

Hint: The Certificate Authority failed to download the temporary challenge files created by Certbot. Ensure that the listed domains serve their content from the provided --webroot-path/-w and that files created there can be downloaded from the internet.

Some challenges have failed.

My web server is (include version):
Only office server

The operating system my web server runs on is (include version):
ubuntu 20.04
My hosting provider, if applicable, is:
Digital Ocean

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

The 404 error when using certbot webroot for nginx is that the webroot folder does not match the root folder value in your nginx config.

Are you updating nginx yourself or are you following some instructions like these?


I am following this

For the option of web hosting product

I tried this one,
Switching ONLYOFFICE Docs to HTTPS protocol - ONLYOFFICE
But not working ,i have this

root@onlyofficedocs700onubuntu2004lts-s-2vcpu-4gb-sgp1-01:~# sudo bash /usr/bin/
bash: /usr/bin/ No such file or directory

Can you show the output of sudo nginx -T

Please put 3 backticks before and after the output - it will be long. Like this:
output of sudo nginx -T


Nginx not installed on my server.
Do i need to install this only for SSL ?


1 Like

My mistake. I thought OnlyOffice used nginx as the underlying server.

I don't know OnlyOffice at all. You should try asking at the OnlyOffice support forums. They are more familiar with how to configure it.


Thanks for your help.
Yes, i am writting to them for the support.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.