Install SSL Let's Encrypt for SLES 12SP3 FIORI

Hello Let’s Encrypt Community . Please help me in this case.
These are all informations that i can provide for you.

  • My domain is: https://s4hana.saphub.xyz
  • The operating system my web server runs on is (include version): LINUX SLES for SAP Application
SUSE Linux Enterprise Server 12 (x86_64)
VERSION = 12
PATCHLEVEL = 3
# This file is deprecated and will be removed in a future service pack or release.
# Please check /etc/os-release for details about this release.
  • I can login to a root shell on my machine (yes or no, or I don’t know): YES
  • I’m using a control panel to manage my site (no, or provide the name and version of the control panel): NO
  • The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):
    i can not install certbot or anything like this. i ran command like this

Loading repository data…
Reading installed packages…
‘certbot’ not found in package names. Trying capabilities.
No provider of ‘certbot’ found.
Resolving package dependencies…
Nothing to do.
After, i added repo SUSE12SP3REPO into server by YAST, i had tried , and system show message “Timeout exceeded when accessing ‘http://ftp5.gwdg.de/pub/opensuse/discontinued/distribution/12.3/repo/oss/content’.” => I understand server is not reposding with my request.
How can i continue ? Because SSL is mandatory for using in mobile.

Thanks all in advance.

Hi @elanidol

I don’t know the details of your Suse. But if the Certbot installation doesn’t work.

Perhaps try Certbot-auto - https://certbot.eff.org/

Or switch to another client like acme.sh.

1 Like

Hi Mr. JuergenAuer,

i will try with your solution and feedback later.

Tks so much.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.