LE on SuSE Linux Enterprise Server - SLES 11


#1

Hi,

just tried to install letsencrypt 0.50 as root on SuSE Linux Enterprise Server - SLES 11 SP4, Kernel V. 3.0.101-63, Python V.2.6.9, with error:

./letsencrypt-auto --help all
Sorry, I don’t know how to bootstrap Let’s Encrypt on your operating system!

You will need to bootstrap, configure virtualenv, and run pip install manually.
Please see https://letsencrypt.readthedocs.org/en/latest/contributing.html#prerequisites
for more info.
Checking for new version…
Creating virtual environment…
/usr/local/bin/virtualenv: line 18: pyenv-root: command not found

Where to find the “pyenv-root” ?
Any ideas?

TIA!


#2

To be honest, I’d use one of the alternate clients on that server. Any of the bash ones should work fine. Using the official client will require a few installs, and I suspect requiring you to upgrade Python.


#3

Yes,

acme.sh would work for you.


#4

Hi ,

just tried to install on SLES 11 server.
Install - OK, but:

acme.sh --issue --apache -d a-i-p.com -d www.a-i-p.com -d user.a-i-p.com -w /srv/www/htdocs --reloadcmd “service apache2 reload”

  • shows errors:
    /root/.acme.sh/acme.sh: line 812: apachectl: command not found
    /root/.acme.sh/acme.sh: line 817: apachectl: command not found
    [Di 19. Apr 09:45:33 GMT-1 2016] Apache Config file not found=’/’
    [Di 19. Apr 09:45:33 GMT-1 2016] set up apache error. Report error to me.

How to correct this?

TIA!


#5

remove the --apache and try again.


#6

Hi Neilpang,

thanks - it looks now a little better:

acme.sh --issue -d a-i-p.com -w /srv/www/htdocs
[Di 19. Apr 11:24:00 GMT-1 2016] Skip register account key
[Di 19. Apr 11:24:00 GMT-1 2016] Creating csr
[Di 19. Apr 11:24:00 GMT-1 2016] Single domain=‘a-i-p.com
[Di 19. Apr 11:24:00 GMT-1 2016] Verify each domain
[Di 19. Apr 11:24:00 GMT-1 2016] Getting webroot for domain=‘a-i-p.com
[Di 19. Apr 11:24:00 GMT-1 2016] Getting token for domain=‘a-i-p.com
[Di 19. Apr 11:24:02 GMT-1 2016] Verifying:a-i-p.com
[Di 19. Apr 11:24:09 GMT-1 2016] a-i-p.com:Verify error:Invalid response from http://a-i-p.com/.well-known/acme-challenge/zuYWfF29pwUD9m8oAT_dJ5hAx-VS75fr3vxIo9AgclE [94.136.22.155]: 404

Do you know, what does this error exactly mean - what is a possible reason?


#7

Please make sure your webroot folder is correct.
you can echo a a.txt in the folder and visit it from the url:

echo aaaa > /srv/www/htdocs/a.txt

http://a-i-p.com/a.txt


#8

Many thanks for your help!

I’m afraid I misunderstand the function of the scipt acme.sh ;-(
We have about 8 server in the company, they all belong to the same domain: a-i-p.com and they all are runing Apache+Tomcat with different applications.
But our WEB server is NOT on our LAN and not in our company. Do I have to install and run the script ONLY on the WEB server? What about those other server - how can I accomplish/produce certificates there?


#9

Thank you for your time @Neilpang! My webroot folder is correct - but on the right server, of course :grinning:
Only one question more:
can I obtain with acme DV certificate for FQDN (Fully Qualif. Domain Name) ?

Best regards


#10

of course. you can obtain certs for any FQDN.

sub.domain.com


#11

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.