Incorrect validation certificate for new domain

Please fill out the fields below so we can help you better.

My domain is:

I ran this command: certbot --apache certonly

It produced this output:
Failed authorization procedure. (tls-sni-01): urn:acme:error:unauthorized :: The client lacks sufficient authorization :: Incorrect validation certificate for tls-sni-01 challenge. Requested 83f0e85944587562426d76ff8d00766a.1a6fb3336731cd86a360a1220a0174ee.acme.invalid from Received 2 certificate(s), first certificate had names “

My web server is (include version): apache 2.x

The operating system my web server runs on is (include version): ubuntu 16.04

My hosting provider, if applicable, is: linode

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

Awhile ago I setup a certificate for and that worked. Now when I try to create a new certificate for any of my other domains I get the above mentioned error. Any help anyone could provide would be greatly appreciated.

Cert mismatch:
TLS 1.2 (server has no preference)
TLS 1.1 (server has no preference)
TLS 1.0 (server has no preference)

And a potential IPv6 issue may be at play (if not properly considered):
Addresses: 2600:3c03::f03c:91ff:feac:f654

Can you try HTTP validation? works
So, should work too.

Still not sure what the problem was but I ran it with dns authentication and it worked. Thanks for your reply.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.