I'am Install jitsi-meet, please help certboot any error

(1)
I ran this command:
sudo certbot --authenticator webroot --installer nginx -w /etc/nginx/sites-enabled/ -d jitsi.mydomain.com

It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator webroot, Installer nginx
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for jitsi.mydomain.com
Using the webroot path /etc/nginx/sites-enabled for all unmatched domains.
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. jitsi.mydomain.com (http-01): urn:ietf:params:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from http://jitsi.nydomain.com/.well-known/acme-challenge/p1NPLJpyDtXtavIf_GGhnQ5EQxNAP9ZYy5JoYsP6ybc [117.104.XXX.XX]: “\r\n404 Not Found\r\n<body bgcolor=“white”>\r\n

404 Not Found

\r\n

IMPORTANT NOTES:

(2)
I ran this command:
sudo certbot --nginx -d jitsi.mydomain.com

It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator nginx, Installer nginx
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for jitsi.mydomain.com
nginx: [emerg] “server_names_hash_bucket_size” directive is duplicate in /etc/nginx/sites-enabled/jitsi.mydomain.com.conf:1
Cleaning up challenges
nginx restart failed:
b’’
b’’

(3)
I ran this command:
/usr/share/jitsi-meet/scripts/install-letsencrypt-cert.sh

It produced this output:
Iam entered email anddres

Reading package lists… Done
Building dependency tree
Reading state information… Done
gcc is already the newest version (4:5.3.1-1ubuntu1).
libffi-dev is already the newest version (3.2.1-4).
augeas-lenses is already the newest version (1.4.0-0ubuntu1.1).
ca-certificates is already the newest version (20170717~16.04.2).
libaugeas0 is already the newest version (1.4.0-0ubuntu1.1).
libssl-dev is already the newest version (1.0.2g-1ubuntu4.15).
openssl is already the newest version (1.0.2g-1ubuntu4.15).
python is already the newest version (2.7.12-1~16.04).
python-dev is already the newest version (2.7.12-1~16.04).
python-virtualenv is already the newest version (15.0.1+ds-3ubuntu1).
virtualenv is already the newest version (15.0.1+ds-3ubuntu1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Creating virtual environment…
Traceback (most recent call last):
File “/usr/lib/python3/dist-packages/virtualenv.py”, line 2363, in
main()
File “/usr/lib/python3/dist-packages/virtualenv.py”, line 719, in main
symlink=options.symlink)
File “/usr/lib/python3/dist-packages/virtualenv.py”, line 988, in create_environment
download=download,
File “/usr/lib/python3/dist-packages/virtualenv.py”, line 918, in install_wheel
call_subprocess(cmd, show_stdout=False, extra_env=env, stdin=SCRIPT)
File “/usr/lib/python3/dist-packages/virtualenv.py”, line 812, in call_subprocess
% (cmd_desc, proc.returncode))
OSError: Command /opt/eff.org/certbot/venv/bin/python2.7 - setuptools pkg_resources pip wheel failed with error code 1
Traceback (most recent call last):
File “”, line 27, in
File “”, line 19, in create_venv
File “/usr/lib/python2.7/subprocess.py”, line 541, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command ‘[‘virtualenv’, ‘–no-site-packages’, ‘–python’, ‘/usr/bin/python2.7’, ‘/opt/eff.org/certbot/venv’]’ returned non-zero exit status 1

My web server is : nginx/1.10.3 (Ubuntu)

The operating system my web server runs on is :
Virtualization: xen
Operating System: Ubuntu 16.04.6 LTS
Kernel: Linux 4.4.0-177-generic
Architecture: x86-64

What’s your real domain name

If the directive is actually duplicated, you need to fix it.

If Certbot is inadvertently duplicating it while modifying your configuration, can you move it elsewhere, e.g. to nginx.conf?

2 Likes

this won’t work. that’s not your webroot path. it should look link /var/www/something

yes thank you, I have moved file .conf
and solve that

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.