I was renewed my ssl certificate today but still when i try to access my website www.spproductions.in its showing the certificate has expired please help

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: www.spproductions.in

I ran this command:

It produced this output:The certificate expired on 04 February 2019, 08:08:05. The current time is 4 February 2019, 12:13. Error code: SEC_ERROR_EXPIRED_CERTIFICATE

My web server is (include version): IIS 7

The operating system my web server runs on is (include version):Windows hosting plesk 12.0.18

My hosting provider, if applicable, is: Godaddy

I can login to a root shell on my machine (yes or no, or I don’t know):yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):plesk 12.0.18

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

Hi @salmanpatel744

how did you create the certificate?

Which client did you used?

Your certificate is expired ( https://check-your-website.server-daten.de/?q=spproductions.in ):

expired	spproductions.in, www.spproductions.in - 2 entries

but your port 80 is open and answers with a correct 404, if a file under /.well-known/acme-challenge is missing.

But i deleted the old files under acme.Challange folder and created new certificate

I created certificate using sslforfree website

Please tell me how can i solve this

Then do it again.

Letsencrypt certificates are only 90 days valide. So you have to repeat these steps every 60 - 85 days.

Or select a client.

Start there:

Yes I created it again but still having problem ssl not working… All steps done successfully like before 3 months i have done but now when I was creating new one it still showing certificate is expired when accessing my website

Yep, there


is a new certificate created today.

But I don't know how Plesk handles that.

After creating the certificate, what are the next steps to install the certificate in your hosting?

needs manually copy and paste the certificate file ca-bundle file and private key to create certificate… And after successfully created… Go to hosting settings check the ssl support and selected the ssl certificate I was created… Same process before 3 months I was used and that worked that time but not now

That was my idea.

But then it looks that it's a problem with your hosting environment. So you should ask your hoster.

I asked the same but he replyed we can’t help you for 3rd party ssl provider

I deleted all the old certificate data and files in well knows and certificate also and created new one is this correct way or not?

Move over to a less user hostile provider. Here is a handy list:

You deleted files?

This is always bad.

Creating a new certificate and uploading it should be enough.

Ok but I did first time… So now how can I resolve plz tell me

Can u please increase limit for my www.spproductions.in it was reached the limit and saying to wait for 7 days… I was trying to sort out problem with hosting provider but now this issue happened please increase my limits

You have valide certificates. The installation is a separate problem. You have to fix your installation problem instead of creating new certificates.

PS: The limit is fixed.

Please just once it’s really important

Is there a built-in way for Plesk to handle the certs?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.