I had to reload my server. How can I set it up now again?


#1

I put my server in another PC now. But I still have the same hard drive that has /var/www I had it link to there.

So how can I set up Let’s Encrypt now?

-Raymond Day


#2

Linux, right?

Following the instructions on http://certbot.eff.org is a good place to start - should give you a certificate by the end of it.


#3

Thank you I did that and I know the port foreword works because I can go to my IP port 443 and my web page comes up.

But when I do a certbot --apache

It says:

T> imeout during connect (likely firewall problem)

To fix these errors, please make sure that your domain name was
entered correctly and the DNS A/AAAA record(s) for that domain
contain(s) the right IP address. Additionally, please check that
your computer has a publicly routable IP address and that no
firewalls are preventing the server from communicating with the
client. If you’re using the webroot plugin, you should also verify
that you are serving files from the webroot path you provided.

Were I get my dhcp name it is right for my IP that like I said I can put in with port 443 and it comes up. I just can’t with https:// and the name I have.

-Raymond Day


#4

Hi @Ray

we need some informations. In #help there is a template:


Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):


#5

Can you reach it via port 80?


#6

no because I did not port foreword that. O I guess that is what’s wrong. I got to foreword port 80 too?

-Raymond Day


#7

Yes, all new renewals will be done via http.


#8

OK I did that and now I get in red, the bold type:

Obtaining a new certificate
An unexpected error occurred:
There were too many requests of a given type :: Error creating new order :: too many failed authorizations recently: see https://letsencrypt.org/docs/rate-limits/
Please see the logfiles in /var/log/letsencrypt for more details.


#9

You will have to wait about an hour.
[maybe less]


#10

LOL. Wow. OK wait a hour. I been working on this for days losing sleep. Want to get my server back up. I waited this long so can wait more.

Thank you.

-Raymond Day


#11

O if I try to soon and it error’s do I have to wait another hour or so?

-Raymond Day


#12

Nothing can be done to change those limits.
Your system tried too many times in the last hour.


#13

The limit is 5 per hour.

So if they had been evenly spread…
That’s only 12 minutes apart.
[but such an even spread would be highly unlikely]

Nonetheless, the point is maybe one is already older than an hour so it’s now down to 4.
And you can try again.
Or use --dry-run which will use the staging environment.
[not affected by that 5/hour limit]


#14

Thank you I waited for time and then it worked.

-Raymond Day