I forgot how to request cert for imap / smtp

Hello

Moving to new hardware Ubuntu 18.04 and have forgotten how to request cert for imap / smtp.

When I attempt the following:

certbot certonly --dry-run --webroot -w /var/www/html --expand -d smtp.domainone.com -d imap.domainone.com -d smtp.domaintwo.com -d imap.domaintwo.com

The following occurs:

 Domain: imap.domainone.com
   Type:   unauthorized
   Detail: Invalid response from
   http://imap.domainone.com/.well-known/acme-challenge/asdfasdfasfasfasfasfd
   [public ip]: "<!DOCTYPE HTML PUBLIC \"-//IETF//DTD HTML
   2.0//EN\">\n<html><head>\n<title>404 Not
   Found</title>\n</head><body>\n<h1>Not Found</h1>\n<p"

   Domain: imap.domaintwo.com
   Type:   unauthorized
   Detail: Invalid response from
   http://imap.domaintwo.com/.well-known/acme-challenge/wwertwertwetwetrwetrwert
   [public ip]: "<!DOCTYPE HTML PUBLIC \"-//IETF//DTD HTML
   2.0//EN\">\n<html><head>\n<title>404 Not
   Found</title>\n</head><body>\n<h1>Not Found</h1>\n<p"

 Domain: smtp.domainone.com
   Type:   unauthorized
   Detail: Invalid response from
   http://smtp.domainone.com/.well-known/acme-challenge/asdfasdfasfasfasfasfd
   [public ip]: "<!DOCTYPE HTML PUBLIC \"-//IETF//DTD HTML
   2.0//EN\">\n<html><head>\n<title>404 Not
   Found</title>\n</head><body>\n<h1>Not Found</h1>\n<p"

   Domain: smtp.domaintwo.com
   Type:   unauthorized
   Detail: Invalid response from
   http://smtp.domaintwo.com/.well-known/acme-challenge/wwertwertwetwetrwetrwert
   [public ip]: "<!DOCTYPE HTML PUBLIC \"-//IETF//DTD HTML
   2.0//EN\">\n<html><head>\n<title>404 Not
   Found</title>\n</head><body>\n<h1>Not Found</h1>\n<p"

Error log file shows errors like:

certbot.errors.FailedChallenges: Failed authorization procedure. imap.domainone.com (http-01): urn:ietf:params:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from http://imap.domainone.com/.well-known/acme-challenge/sdgsdfgsdfgsdfgsdgf [public ip]: "<!DOCTYPE HTML PUBLIC \"-//IETF//DTD HTML 2.0//EN\">\n<html><head>\n<title>404 Not Found</title>\n</head><body>\n<h1>Not Found</h1>\n<p"

On the previous system I do not have .well-known directories for each of the imap and smtp.

Iā€™m checking for any type of alias for the .well-known and but they are committed out in the 000 apache2 file on the old system.

Not sure what to do and could use some assistance.

1 Like

Fixed it.

Was a permissions problem.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.